summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0f8fd4d270..956bac151a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4756,14 +4756,17 @@ color scales, and color space conversion easy. It has support for:
("texinfo" ,texinfo)
("perl" ,perl)
("scipy-sphinx-theme"
- ,(origin ; The build script expects scipy-sphinx-theme as a git submodule
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/scipy/scipy-sphinx-theme")
- (commit "c466764e2231ba132c09826b5b138fffa1cfcec3")))
- (sha256
- (base32
- "0q2y87clwlsgc7wvlsn9pzyssybcq10plwhq2w1ydykfsyyqbmkl"))))
+ ,(let ((commit "c466764e2231ba132c09826b5b138fffa1cfcec3"))
+ (origin ;the build script expects scipy-sphinx-theme as a git submodule
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/scipy/scipy-sphinx-theme")
+ (commit commit)))
+ (file-name (git-file-name "python-scipy-sphinx-theme"
+ (string-take commit 7)))
+ (sha256
+ (base32
+ "0q2y87clwlsgc7wvlsn9pzyssybcq10plwhq2w1ydykfsyyqbmkl")))))
,@(package-native-inputs python-numpy)))
(arguments
`(#:tests? #f ; we're only generating the documentation