summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 95fab20247..8e1f0fd807 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19084,21 +19084,19 @@ multitouch applications.")
(base32 "19iiys4233cicpm48fd7lrkm31kk47qiv44wvk952rqbcn4rd2dh"))))
(build-system python-build-system)
(propagated-inputs
- (list python-lazy-object-proxy python-wrapt))
+ (list python-lazy-object-proxy python-typing-extensions python-wrapt))
(native-inputs
- (list python-pytest python-pytest-runner python-typing-extensions))
+ (list python-pytest python-pytest-runner))
(home-page "https://github.com/PyCQA/astroid")
- (synopsis "Common base representation of python source code for pylint and
- other projects")
+ (synopsis "Python source code base representation")
(description "@code{python-astroid} provides a common base representation
- of python source code for projects such as pychecker, pyreverse, pylint, etc.
-
- It provides a compatible representation which comes from the _ast module. It
- rebuilds the tree generated by the builtin _ast module by recursively walking
- down the AST and building an extended ast. The new node classes have
- additional methods and attributes for different usages. They include some
- support for static inference and local name scopes. Furthermore, astroid
- builds partial trees by inspecting living objects.")
+of Python source code for projects such as pychecker, pyreverse, pylint, etc.
+It provides a compatible representation which comes from the _ast module. It
+rebuilds the tree generated by the builtin _ast module by recursively walking
+down the AST and building an extended ast. The new node classes have
+additional methods and attributes for different usages. They include some
+support for static inference and local name scopes. Furthermore, astroid
+builds partial trees by inspecting living objects.")
(license license:lgpl2.1+)))
(define-public python-isbnlib