summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a414a9d9de..662f511762 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -73,7 +73,17 @@
;; config.
;; "--sysconfdir=/etc"
- "--with-session-socket-dir=/tmp")))
+ "--with-session-socket-dir=/tmp")
+ #:phases (alist-cons-after
+ 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; 'dbus-launch' bails out if the 'session.d' directory
+ ;; below is missing, so create it along with its companion.
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir (string-append out "/etc/dbus-1/session.d"))
+ (mkdir (string-append out "/etc/dbus-1/system.d"))
+ #t))
+ %standard-phases)))
(inputs
`(("expat" ,expat)
("pkg-config" ,pkg-config)