summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/services/security-token.scm84
-rw-r--r--gnu/tests/security-token.scm71
3 files changed, 157 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e14657c2d1..e3ca237d87 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -486,6 +486,7 @@ GNU_SYSTEM_MODULES = \
%D%/services/monitoring.scm \
%D%/services/networking.scm \
%D%/services/nfs.scm \
+ %D%/services/security-token.scm \
%D%/services/shepherd.scm \
%D%/services/sound.scm \
%D%/services/herd.scm \
@@ -540,6 +541,7 @@ GNU_SYSTEM_MODULES = \
%D%/tests/messaging.scm \
%D%/tests/networking.scm \
%D%/tests/rsync.scm \
+ %D%/tests/security-token.scm \
%D%/tests/ssh.scm \
%D%/tests/version-control.scm \
%D%/tests/virtualization.scm \
diff --git a/gnu/services/security-token.scm b/gnu/services/security-token.scm
new file mode 100644
index 0000000000..7e7ea54a50
--- /dev/null
+++ b/gnu/services/security-token.scm
@@ -0,0 +1,84 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu services security-token)
+ #:use-module (gnu services)
+ #:use-module (gnu services shepherd)
+ #:use-module (gnu packages admin)
+ #:use-module (gnu packages security-token)
+ #:use-module (gnu system shadow)
+ #:use-module (guix gexp)
+ #:use-module (guix modules)
+ #:use-module (guix records)
+ #:use-module (ice-9 match)
+ #:use-module (srfi srfi-26)
+ #:export (pcscd-configuration
+ pcscd-configuration?
+ pcscd-configuration-pcsc-lite
+ pcscd-configuration-usb-drivers
+ pcscd-service-type))
+
+;;;
+;;; PC/SC Smart Card Daemon
+;;;
+
+(define-record-type* <pcscd-configuration>
+ pcscd-configuration make-pcscd-configuration pcscd-configuration?
+ (pcsc-lite pcscd-configuration-pcsc-lite
+ (default pcsc-lite))
+ (usb-drivers pcscd-configuration-usb-drivers
+ (default (list ccid))))
+
+(define pcscd-shepherd-service
+ (match-lambda
+ (($ <pcscd-configuration> pcsc-lite)
+ (with-imported-modules (source-module-closure
+ '((gnu build shepherd)))
+ (shepherd-service
+ (documentation "PC/SC Smart Card Daemon")
+ (provision '(pcscd))
+ (requirement '(syslogd))
+ (modules '((gnu build shepherd)))
+ (start #~(lambda _
+ (invoke #$(file-append pcsc-lite "/sbin/pcscd"))
+ (call-with-input-file "/var/run/pcscd/pcscd.pid" read)))
+ (stop #~(make-kill-destructor)))))))
+
+(define pcscd-activation
+ (match-lambda
+ (($ <pcscd-configuration> pcsc-lite usb-drivers)
+ #~(begin
+ (use-modules (guix build utils))
+ (mkdir-p "/var/lib")
+ (symlink #$(directory-union
+ "pcsc"
+ (map (cut file-append <> "/pcsc")
+ usb-drivers))
+ "/var/lib/pcsc")))))
+
+(define pcscd-service-type
+ (service-type
+ (name 'pcscd)
+ (description
+ "Run @command{pcscd}, the PC/SC smart card daemon.")
+ (extensions
+ (list (service-extension shepherd-root-service-type
+ (compose list pcscd-shepherd-service))
+ (service-extension activation-service-type
+ pcscd-activation)))
+ (default-value (pcscd-configuration))))
diff --git a/gnu/tests/security-token.scm b/gnu/tests/security-token.scm
new file mode 100644
index 0000000000..1169a4b9fd
--- /dev/null
+++ b/gnu/tests/security-token.scm
@@ -0,0 +1,71 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu tests security-token)
+ #:use-module (gnu tests)
+ #:use-module (gnu system vm)
+ #:use-module (gnu services)
+ #:use-module (gnu services security-token)
+ #:use-module (guix gexp)
+ #:export (%test-pcscd))
+
+(define %pcscd-os
+ (simple-operating-system
+ (service pcscd-service-type)))
+
+(define* (run-pcscd-test)
+ "Run tests of 'pcscd-service-type'."
+ (define os
+ (marionette-operating-system
+ %pcscd-os
+ #:imported-modules '((gnu services herd))
+ #:requirements '(pcscd)))
+
+ (define test
+ (with-imported-modules '((gnu build marionette))
+ #~(begin
+ (use-modules (srfi srfi-64)
+ (gnu build marionette))
+ (define marionette
+ (make-marionette (list #$(virtual-machine os))))
+
+ (mkdir #$output)
+ (chdir #$output)
+
+ (test-begin "pcscd")
+
+ (test-assert "pcscd is alive"
+ (marionette-eval
+ '(begin
+ (use-modules (gnu services herd))
+ (live-service-running
+ (find (lambda (live)
+ (memq 'pcscd (live-service-provision live)))
+ (current-services))))
+ marionette))
+
+ (test-end)
+ (exit (= (test-runner-fail-count (test-runner-current)) 0)))))
+
+ (gexp->derivation "pcscd" test))
+
+(define %test-pcscd
+ (system-test
+ (name "pcscd")
+ (description "Test a running pcscd daemon.")
+ (value (run-pcscd-test))))