summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 23934196db..e880ad8c78 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2521,9 +2521,14 @@ version numbers.")
(base32
"0hddbqjm4jq63y8jf44nswina1crjs16l9snb6m3vvgyg31klrrn"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check (lambda _ (zero? (system* "nosetests")))))))
(native-inputs
- `(("python-vcversioner" ,python-vcversioner)))
- (home-page "http://github.com/Julian/jsonschema")
+ `(("python-nose" ,python-nose)
+ ("python-vcversioner" ,python-vcversioner)))
+ (home-page "https://github.com/Julian/jsonschema")
(synopsis "Implementation of JSON Schema for Python")
(description
"Jsonschema is an implementation of JSON Schema for Python.")
@@ -2535,7 +2540,8 @@ version numbers.")
(strip-python2-variant python-jsonschema))))
(package (inherit jsonschema)
(native-inputs
- `(("python2-setuptools" ,python2-setuptools)
+ `(("python2-mock" ,python2-mock)
+ ("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs jsonschema)))
(propagated-inputs
`(("python2-functools32" ,python2-functools32))))))