summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d1aaa40c71..d7b3eb1f34 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31880,6 +31880,30 @@ normally prevent moving a type that has been borrowed from.")
"This package provides a library for padding strings at runtime.")
(license license:expat)))
+(define-public rust-pager-0.15
+ (package
+ (name "rust-pager")
+ (version "0.15.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pager" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0a35mg68s0p63ya2k5hsg620c4llkjw2fx1sfi0laz4pz8myv75n"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-errno" ,rust-errno-0.2)
+ ("rust-libc" ,rust-libc-0.2))))
+ (home-page "https://gitlab.com/imp/pager-rs.git")
+ (synopsis "Helps pipe your output through an external pager")
+ (description
+ "This package pipes your Rust output through an external pager.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-palette-0.5
(package
(name "rust-palette")