summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index fb50c25c09..b16b2a3f1f 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -177,8 +177,16 @@ parser modules).")
(base32
"0dp5nxq491gymq806za0dk4hngfmq65ysrqbn0ypajqbbl6vf71n"))))
(build-system gnu-build-system)
+ (arguments
+ ;; Make sure the reference to util-linux's 'getopt' is kept in 'xmlto'.
+ '(#:configure-flags (list (string-append "GETOPT="
+ (assoc-ref %build-inputs
+ "util-linux")
+ "/bin/getopt"))))
(inputs
- `(("util-linux" ,util-linux)))
+ `(("util-linux" ,util-linux) ; for 'getopt'
+ ("libxml2" ,libxml2) ; for 'xmllint'
+ ("libxslt" ,libxslt))) ; for 'xsltproc'
(home-page "http://cyberelk.net/tim/software/xmlto/")
(synopsis "Front-end to an XSL toolchain")
(description