summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a827bdeb14..b96514c2e4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7466,7 +7466,9 @@ Cuffdiff or Ballgown programs.")
(replace 'check
;; Note, this fails to run with "-v" as it tries to write to a
;; closed output stream.
- (lambda _ (invoke "python" "-m" "unittest") #t)))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest")))))))
(propagated-inputs
`(("python-sqlalchemy" ,python-sqlalchemy)
("python-decorator" ,python-decorator)