summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 72006ff905..87dd5f2cf9 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2210,6 +2210,17 @@ simulation of the Hyperion Fuzz pedal."))))
(base32
"1ji915bly588a8xwvwspvsqv0nh8ljgi6rky2mk1d9d6nz96jrbk"))
(file-name (string-append name "-" version "-checkout"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments gx-guvnor-lv2)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'escape-shell-commands
+ (lambda _
+ (substitute* "Makefile"
+ (("cat ") "$(shell cat ")
+ (("/dev/null") "/dev/null)")
+ (("SSE_CFLAGS = \"\"") "SSE_CFLAGS ="))
+ #t))))))
(home-page "https://github.com/brummer10/GxVoodoFuzz.lv2")
(synopsis "Fuzz effect modelled after the Voodoo Lab SuperFuzz")
(description "This package provides the LV2 plugin \"GxVoodooFuzz\", a