summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 8306dbf868..36424ee8b1 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2573,12 +2573,9 @@ new Date();"))
;; The build system copies a few .template files from the
;; source directory into the build directory and then modifies
;; them in-place. So these files have to be writable.
- (for-each
- (lambda (file)
- (invoke "chmod" "u+w" file))
+ (for-each make-file-writable
(find-files "src/java.base/share/classes/jdk/internal/misc/"
- "\\.template$"))
- #t))))))
+ "\\.template$"))))))))
(home-page "https://openjdk.java.net/projects/jdk/16")))
(define-public openjdk17