summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 445d5b91ad..e826609bca 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -335,7 +335,23 @@ printing and other features typical of a source code editor.")
"062x2gqd7p6yxhxlib1ha4l3gk9ihcj080hrwwv9vmlmybb064hi"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--with-x11")))
+ '(#:configure-flags '("--with-x11")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "tests/Makefile.in"
+ ;; XXX FIXME: This test fails on some machines with:
+ ;; GLib-FATAL-ERROR: gmem.c:103: failed to allocate
+ ;; 6039798016 bytes
+ (("cve-2015-4491\\$\\(EXEEXT\\) ") "")
+ ;; XXX FIXME: This test fails with:
+ ;; ERROR:pixbuf-jpeg.c:74:test_type9_rotation_exif_tag:
+ ;; assertion failed (error == NULL): Data differ
+ ;; (gdk-pixbuf-error-quark, 0)
+ (("pixbuf-jpeg\\$\\(EXEEXT\\) ") ""))
+ #t)))))
(propagated-inputs ; required by gdk-pixbuf-2.0.pc
`(("glib" ,glib)
("libpng" ,libpng)))
@@ -347,22 +363,6 @@ printing and other features typical of a source code editor.")
`(("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection", gobject-introspection))) ; g-ir-compiler, etc.
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-after
- 'unpack 'disable-failing-tests
- (lambda _
- (substitute* "tests/Makefile.in"
- ;; XXX FIXME: This test fails on some machines with:
- ;; GLib-FATAL-ERROR: gmem.c:103: failed to allocate
- ;; 6039798016 bytes
- (("cve-2015-4491\\$\\(EXEEXT\\) ") "")
- ;; XXX FIXME: This test fails with:
- ;; ERROR:pixbuf-jpeg.c:74:test_type9_rotation_exif_tag:
- ;; assertion failed (error == NULL): Data differ
- ;; (gdk-pixbuf-error-quark, 0)
- (("pixbuf-jpeg\\$\\(EXEEXT\\) ") ""))
- #t)))))
(synopsis "GNOME image loading and manipulation library")
(description
"GdkPixbuf is a library for image loading and manipulation developed