summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/check.scm9
-rw-r--r--gnu/packages/compression.scm2
-rw-r--r--gnu/packages/freedesktop.scm14
-rw-r--r--gnu/packages/gl.scm8
-rw-r--r--gnu/packages/glib.scm8
-rw-r--r--gnu/packages/gnome.scm4
-rw-r--r--gnu/packages/graphviz.scm70
-rw-r--r--gnu/packages/gtk.scm21
-rw-r--r--gnu/packages/linux.scm8
-rw-r--r--gnu/packages/patches/gdk-pixbuf-list-dir.patch35
-rw-r--r--gnu/packages/video.scm14
-rw-r--r--gnu/packages/xdisorg.scm11
13 files changed, 87 insertions, 118 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 643a88db81..26ecd068e5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -630,7 +630,6 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-6-cross-environment-variables.patch \
%D%/packages/patches/gcr-disable-failing-tests.patch \
%D%/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch \
- %D%/packages/patches/gdk-pixbuf-list-dir.patch \
%D%/packages/patches/gd-fix-gd2-read-test.patch \
%D%/packages/patches/gd-fix-tests-on-i686.patch \
%D%/packages/patches/gd-freetype-test-failure.patch \
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 198bb81f8e..f978ef3055 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -76,11 +76,10 @@ source code editors and IDEs.")
"057j82da9vv4li4z5ri3227ybd18nzyq81f6gsvhifs5z0vr3cpm"))))
(build-system gnu-build-system)
(arguments '(#:phases
- (alist-cons-before
- 'configure 'autoconf
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'configure 'autoconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
(native-inputs
`(("automake" ,automake)
("autoconf" ,autoconf)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index a6758e9471..b6cbfee584 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -470,7 +470,7 @@ some compression ratio).")
(description
"Lzip is a lossless data compressor with a user interface similar to the
one of gzip or bzip2. Lzip decompresses almost as fast as gzip and compresses
-more than bzip2, which makes it well suited for software distribution and data
+more than bzip2, which makes it well-suited for software distribution and data
archiving. Lzip is a clean implementation of the LZMA algorithm.")
(license license:gpl3+)))
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index f99f9771e3..a304c15334 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -367,7 +367,19 @@ Python.")
(base32
"0lgywr1m0d79vr4s8aimj8a307nss29hhy68gjpqj7m667055c39"))))
(build-system gnu-build-system)
- (arguments `(#:parallel-tests? #f))
+ (arguments
+ `(#:parallel-tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Remove record shapes to workaround graphviz 2.40.1 problems.
+ ;; http://www.graphviz.org/content/i-havent-been-able-render-these-files-graphviz-226
+ ;; This will likely be fixed upstream in the next release.
+ ;; https://lists.freedesktop.org/archives/wayland-devel/2017-June/034218.html
+ (add-before 'build 'fix-graphviz
+ (lambda _
+ (substitute* "doc/doxygen/dot/x-architecture.gv"
+ (("Mrecord") "none"))
+ #t)))))
(native-inputs
`(("doxygen" ,doxygen)
("graphviz" ,graphviz)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index d017e375c9..cc1dcf9edf 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -217,17 +217,19 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "17.1.4")
+ (version "17.1.8")
(source
(origin
(method url-fetch)
- (uri (list (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
+ (uri (list (string-append "https://mesa.freedesktop.org/archive/"
+ "mesa-" version ".tar.xz")
+ (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
"mesa-" version ".tar.xz")
(string-append "ftp://ftp.freedesktop.org/pub/mesa/"
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "1bcwxin7nmbnv92xav381b6qxscsx1zzc71ryfvj03cglbkb1wq6"))
+ "1nv9aaz7ay2bs4fc8j3rf6ky3qla8s346a8g2lvdbp96msp2xvbm"))
(patches
(search-patches "mesa-wayland-egl-symbols-check-mips.patch"
"mesa-skip-disk-cache-test.patch"))))
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index c5c48731fe..8408b54ea2 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -67,7 +67,7 @@
(define dbus
(package
(name "dbus")
- (version "1.10.18")
+ (version "1.10.22")
(source (origin
(method url-fetch)
(uri (string-append
@@ -75,7 +75,7 @@
version ".tar.gz"))
(sha256
(base32
- "0jjirhw6xwz2ffmbg5kr79108l8i1bdaw7szc67n3qpkygaxsjb0"))
+ "15vv9gz5i4f5l7h0d045qz5iyvl89hjk2k83lb4vbizd7qg41cg2"))
(patches (search-patches "dbus-helper-search-path.patch"))))
(build-system gnu-build-system)
(arguments
@@ -137,7 +137,7 @@ shared NFS home directories.")
(define glib
(package
(name "glib")
- (version "2.52.2")
+ (version "2.52.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/"
@@ -145,7 +145,7 @@ shared NFS home directories.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1l65kab6jr9zlllgbjcbvrbgah3sdd577fpw4pdb2j195ag5s3ph"))
+ "0a71wkkhkvad84gm30w13micxxgqqw3sxhybj7nd9z60lwspdvi5"))
(patches (search-patches "glib-tests-timer.patch"))))
(build-system gnu-build-system)
(outputs '("out" ; everything
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5c94ceb036..efb998764d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1163,7 +1163,7 @@ dealing with different structured file formats.")
(define-public librsvg
(package
(name "librsvg")
- (version "2.40.17")
+ (version "2.40.18")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1171,7 +1171,7 @@ dealing with different structured file formats.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1k39gyf7f5m9x0jvpcxvfcqswdb04xhm1lbwbjabn1f4xk5wbxp6"))))
+ "0k2nbd4g31qinkdfd8r5c5ih2ixl85fbkgkqqh9747lwr24c9j5z"))))
(build-system gnu-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index d47d45e527..6724ba6d7d 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -44,51 +44,41 @@
(define-public graphviz
(package
(name "graphviz")
- (version "2.38.0")
+ (version "2.40.1")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://www.graphviz.org/pub/graphviz/ARCHIVE/graphviz-"
- version ".tar.gz"))
- (sha256
- (base32
- "17l5czpvv5ilmg17frg0w4qwf89jzh2aglm9fgx0l0aakn6j7al1"))))
+ (method url-fetch)
+ (uri (string-append
+ "http://www.graphviz.org/pub/graphviz/ARCHIVE/graphviz-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "08d4ygkxz2f553bxj6087da56a23kx1khv0j8ycxa102vvx1hlna"))))
(build-system gnu-build-system)
(arguments
;; FIXME: rtest/rtest.sh is a ksh script (!). Add ksh as an input.
'(#:tests? #f
-
- #:phases (alist-cons-before
- 'build 'pre-build
- (lambda _
- ;; Work around bogus makefile when using an external
- ;; libltdl. Failing to do so, one hits this error:
- ;; "No rule to make target `-lltdl', needed by `libgvc.la'."
- (substitute* "lib/gvc/Makefile"
- (("am__append_5 *=.*")
- "am_append_5 =\n")))
- (alist-cons-after
- 'install 'move-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc")))
- (mkdir-p (string-append doc "/share/graphviz"))
- (rename-file (string-append out "/share/graphviz/doc")
- (string-append doc "/share/graphviz/doc"))
- #t))
- (alist-cons-after
- 'move-docs 'move-guile-bindings
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib"))
- (extdir (string-append lib
- "/guile/2.0/extensions")))
- (mkdir-p extdir)
- (rename-file (string-append
- lib "/graphviz/guile/libgv_guile.so")
- (string-append extdir
- "/libgv_guile.so"))))
- %standard-phases)))))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share/graphviz"))
+ (rename-file (string-append out "/share/graphviz/doc")
+ (string-append doc "/share/graphviz/doc"))
+ #t)))
+ (add-after 'move-docs 'move-guile-bindings
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib"))
+ (extdir (string-append lib
+ "/guile/2.0/extensions")))
+ (mkdir-p extdir)
+ (rename-file (string-append
+ lib "/graphviz/guile/libgv_guile.so")
+ (string-append extdir
+ "/libgv_guile.so"))
+ #t))))))
(inputs
`(("libXrender" ,libxrender)
("libX11" ,libx11)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 1ea051bfb0..9de7c5b721 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -105,14 +105,14 @@ tools have full access to view and control running applications.")
(define-public cairo
(package
(name "cairo")
- (version "1.14.8")
+ (version "1.14.10")
(source (origin
(method url-fetch)
(uri (string-append "https://cairographics.org/releases/cairo-"
version ".tar.xz"))
(sha256
(base32
- "082ypjlh03ss5616amgjp9ap3xwwccyh2knyyrj1a4d4x65dkwni"))
+ "02banr0wxckq62nbhc3mqidfdh2q956i2r7w2hd9bjgjb238g1vy"))
(patches (search-patches "cairo-CVE-2016-9082.patch"))))
(build-system gnu-build-system)
(propagated-inputs
@@ -171,7 +171,7 @@ affine transformation (scale, rotation, shear, etc.).")
(define-public harfbuzz
(package
(name "harfbuzz")
- (version "1.4.6")
+ (version "1.5.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.freedesktop.org/software/"
@@ -179,7 +179,7 @@ affine transformation (scale, rotation, shear, etc.).")
version ".tar.bz2"))
(sha256
(base32
- "14yj514yfy373np3gxk930a443j1zgnwg6mm0kdzzjr0rn0qp9r1"))))
+ "1haansza0v2908xycv3xwrw2c42z5p96vdzy11vkzl787cvfr260"))))
(build-system gnu-build-system)
(outputs '("out"
"bin")) ; 160K, only hb-view depend on cairo
@@ -209,7 +209,7 @@ affine transformation (scale, rotation, shear, etc.).")
(define-public pango
(package
(name "pango")
- (version "1.40.6")
+ (version "1.40.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/pango/"
@@ -217,7 +217,7 @@ affine transformation (scale, rotation, shear, etc.).")
name "-" version ".tar.xz"))
(sha256
(base32
- "0wz5b5knpw4gfvz3ny8l6h2ca3bpqqyh55mffkyzgsd1hdrjn5fa"))))
+ "1z0w2vrx3qh3aryfkbfijkcxxr3yjbxc2l4b0yy8rcp2wjlakwbm"))))
(build-system gnu-build-system)
(propagated-inputs
`(("cairo" ,cairo)
@@ -427,7 +427,7 @@ highlighting and other features typical of a source code editor.")
(define-public gdk-pixbuf
(package
(name "gdk-pixbuf")
- (version "2.36.6")
+ (version "2.36.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -435,8 +435,7 @@ highlighting and other features typical of a source code editor.")
name "-" version ".tar.xz"))
(sha256
(base32
- "034279k49ydawnagqd7b1rz741n20k4y3grybzwp26zd146bjpj5"))
- (patches (search-patches "gdk-pixbuf-list-dir.patch"))))
+ "02klisz3ly0bvflj39x49lnl4mnldsgvkjdvnla1as8szxqv44w0"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-x11")
@@ -654,7 +653,7 @@ application suites.")
(name "gtk+")
;; NOTE: When updating the version of 'gtk+', the hash of 'mate-themes' in
;; mate.scm will also need to be updated.
- (version "3.22.15")
+ (version "3.22.20")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -662,7 +661,7 @@ application suites.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1nqgb71vx222g9fd2p017948hqybnyi69xs3n2d64clim7115868"))
+ "1n82ki9sbdnaz6k5f5k3vgd7g4756j6acfbl1bf617w0lyc0kjbh"))
(patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"
"gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch"))))
(outputs '("out" "bin" "doc"))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 245b36f2c6..01e895f4af 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -501,7 +501,7 @@ providing the system administrator with some help in common tasks.")
(define-public util-linux
(package
(name "util-linux")
- (version "2.30")
+ (version "2.30.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/utils/"
@@ -509,7 +509,7 @@ providing the system administrator with some help in common tasks.")
name "-" version ".tar.xz"))
(sha256
(base32
- "13d0ax8bcapga8phj2nclx86w57ddqxbr98ajibpzjq6d7zs8262"))
+ "0hdq2fz405a89fyha4bgwg0rx8b65inxq17w8fg8qhmcj4x3dr0v"))
(patches (search-patches "util-linux-tests.patch"))
(modules '((guix build utils)))
(snippet
@@ -3021,7 +3021,7 @@ Bluetooth audio output devices like headphones or loudspeakers.")
(define-public bluez
(package
(name "bluez")
- (version "5.45")
+ (version "5.46")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3029,7 +3029,7 @@ Bluetooth audio output devices like headphones or loudspeakers.")
version ".tar.xz"))
(sha256
(base32
- "1sb4aflgyrl7apricjipa8wx95qm69yja0lmn2f19g560c3v1b2c"))))
+ "0a4fj343bdqsfyv12hmj9nym0ilsf0bvm54a4apbiby16ww3vayx"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/patches/gdk-pixbuf-list-dir.patch b/gnu/packages/patches/gdk-pixbuf-list-dir.patch
deleted file mode 100644
index 137914a19c..0000000000
--- a/gnu/packages/patches/gdk-pixbuf-list-dir.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Sort directory entries so that the output of
-‘gdk-pixbuf-query-loaders’ is deterministic.
-
-See: https://bugzilla.gnome.org/show_bug.cgi?id=777332
---- gdk-pixbuf-2.34.0/gdk-pixbuf/queryloaders.c.orig 2017-01-11 00:17:32.865843062 +0100
-+++ gdk-pixbuf-2.34.0/gdk-pixbuf/queryloaders.c 2017-01-16 16:12:03.420667874 +0100
-@@ -354,16 +354,27 @@
-
- dir = g_dir_open (path, 0, NULL);
- if (dir) {
-+ GList *entries = NULL;
- const char *dent;
-
- while ((dent = g_dir_read_name (dir))) {
- gint len = strlen (dent);
- if (len > SOEXT_LEN &&
- strcmp (dent + len - SOEXT_LEN, SOEXT) == 0) {
-- query_module (contents, path, dent);
-+ entries = g_list_append (entries, g_strdup (dent));
- }
- }
- g_dir_close (dir);
-+ /* Sort directory entries so that the output of
-+ ‘gdk-pixbuf-query-loaders’ is deterministic. */
-+ entries = g_list_sort (entries, (GCompareFunc) strcmp);
-+ GList *xentries;
-+ for (xentries = entries; xentries; xentries = g_list_next (xentries)) {
-+ dent = xentries->data;
-+ query_module (contents, path, dent);
-+ g_free (xentries->data);
-+ }
-+ g_list_free (entries);
- }
- #else
- g_string_append_printf (contents, "# dynamic loading of modules not supported\n");
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3924e93f96..65e8e1965b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -530,15 +530,19 @@ libebml is a C++ library to read and write EBML files.")
(define-public libva
(package
(name "libva")
- (version "1.8.2")
+ (version "1.8.3")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://www.freedesktop.org/software/vaapi/releases/libva/libva-"
- version".tar.bz2"))
+ (uri (list
+ ;; Newer releases are only available on GitHub.
+ (string-append "https://github.com/01org/libva/releases/download/"
+ version "/libva-" version ".tar.bz2")
+ ;; Keep the old URL around for compatibility.
+ (string-append "https://www.freedesktop.org/software/vaapi/releases/"
+ "libva/libva-" version "/libva-" version ".tar.bz2")))
(sha256
- (base32 "1pnfl3q7dzxs26l3jk9xi97gr0qwnaz6dhvf9ifp2yplr3fy7lwy"))))
+ (base32 "16xbk0awl7wp0vy0nyjvxk11spbw25mp8kwd9bmhd6x9xffi5vjn"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index edb70a37a8..abfa1aec74 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -287,7 +287,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.81")
+ (version "2.4.83")
(source
(origin
(method url-fetch)
@@ -297,15 +297,14 @@ rasterisation.")
".tar.bz2"))
(sha256
(base32
- "1bhimr6za2ddisrvrv1qqd7c2a59s7jc954sjycq2w68b8cmrh4c"))
+ "1minzvsyz5hgm6ixpj8ysa6jsv7vm8qc8nx390jxdsk0v9ljd983"))
(patches (search-patches "libdrm-symbol-check.patch"))))
(build-system gnu-build-system)
(inputs
- `(("libpciaccess" ,libpciaccess)
- ("libpthread-stubs" ,libpthread-stubs)))
+ `(("libpciaccess" ,libpciaccess)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "http://dri.freedesktop.org/wiki/")
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://dri.freedesktop.org/wiki/")
(synopsis "Direct rendering userspace library")
(description "The Direct Rendering Infrastructure, also known as the DRI,
is a framework for allowing direct access to graphics hardware under the