summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0066d6073e..c3d9fcabea 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14827,7 +14827,17 @@ continue.")
("emacs-undercover" ,emacs-undercover)))
(arguments
`(#:tests? #t
- #:test-command '("ert-runner")))
+ #:test-command '("ert-runner")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-refs-next-match-test
+ ;; Hack to disable the failing test for emacs27
+ ;; https://github.com/Wilfred/elisp-refs/issues/29
+ (lambda _
+ (substitute* "test/unit-test.el"
+ (("ert-deftest elisp-refs-next-match")
+ "defun elisp-refs-next-match"))
+ #t)))))
(home-page "https://github.com/Wilfred/elisp-refs")
(synopsis "Find callers of elisp functions or macros")
(description "Find references to functions, macros or variables. Unlike a