summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/global.scm17
-rw-r--r--gnu/packages/libdaemon.scm61
-rw-r--r--gnu/packages/libpng.scm6
-rw-r--r--gnu/packages/patches/vpnc-script.patch15
-rw-r--r--gnu/packages/screen.scm2
-rw-r--r--gnu/packages/vpn.scm66
-rw-r--r--gnu/packages/xml.scm34
7 files changed, 187 insertions, 14 deletions
diff --git a/gnu/packages/global.scm b/gnu/packages/global.scm
index b604ab6478..6ef36d5aea 100644
--- a/gnu/packages/global.scm
+++ b/gnu/packages/global.scm
@@ -28,15 +28,14 @@
(define-public global ; a global variable
(package
(name "global")
- (version "6.2.7")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/global/global-"
- version ".tar.gz"))
- (sha256
- (base32
- "1dr250kz65wqpbms4lhz857mzmvmpmiaxgyqxvxkb4b0s840i14i"))))
+ (version "6.2.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/global/global-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1l6g51kff5010gwmw08jbks1mssgddz7wggjvfsky3g000jkpvf1"))))
(build-system gnu-build-system)
(inputs `(("ncurses" ,ncurses)
("libtool" ,libtool)))
diff --git a/gnu/packages/libdaemon.scm b/gnu/packages/libdaemon.scm
new file mode 100644
index 0000000000..0c77e280ac
--- /dev/null
+++ b/gnu/packages/libdaemon.scm
@@ -0,0 +1,61 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages libdaemon)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public libdaemon
+ (package
+ (name "libdaemon")
+ (version "0.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://0pointer.de/lennart/projects/libdaemon/libdaemon-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0d5qlq5ab95wh1xc87rqrh1vx6i8lddka1w3f1zcqvcqdxgyn8zx"))))
+ (build-system gnu-build-system)
+ (home-page "http://0pointer.de/lennart/projects/libdaemon/")
+ (synopsis "Lightweight C library that eases the writing of UNIX daemons")
+ (description
+ "libdaemon is a lightweight C library that eases the writing of UNIX
+daemons. It consists of the following parts:
+
+ • A wrapper around fork() which does the correct daemonization procedure of
+ a process
+
+ • A wrapper around syslog() for simpler and compatible log output to Syslog
+ or STDERR
+
+ • An API for writing PID files
+
+ • An API for serializing UNIX signals into a pipe for usage with select() or
+ poll()
+
+ • An API for running subprocesses with STDOUT and STDERR redirected to
+ syslog.
+
+APIs like these are used in most daemon software available. It is not that
+simple to get it done right and code duplication is not a goal.")
+ (license lgpl2.1+)))
diff --git a/gnu/packages/libpng.scm b/gnu/packages/libpng.scm
index d351ddcbf7..06facc9a9a 100644
--- a/gnu/packages/libpng.scm
+++ b/gnu/packages/libpng.scm
@@ -27,15 +27,15 @@
(define-public libpng
(package
(name "libpng")
- (version "1.5.13")
+ (version "1.5.14")
(source (origin
(method url-fetch)
(uri (string-append
"http://downloads.sourceforge.net/project/libpng/libpng15/"
version "/libpng-"
- version ".tar.gz"))
+ version ".tar.xz"))
(sha256 (base32
- "0dbh332qjhm3pa8m4ac73rk7dbbmigbqd3ch084m24ggg9qq4k0d"))))
+ "0m3vz3gig7s63zanq5b1dgb5ph12qm0cylw4g4fbxlsq3f74hn8l"))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)))
(synopsis "Libpng, a library for handling PNG files")
diff --git a/gnu/packages/patches/vpnc-script.patch b/gnu/packages/patches/vpnc-script.patch
new file mode 100644
index 0000000000..a0d9481952
--- /dev/null
+++ b/gnu/packages/patches/vpnc-script.patch
@@ -0,0 +1,15 @@
+This patch adapts the vpnc script to newer kernel versions, see
+ https://lkml.org/lkml/2011/3/24/645
+
+diff -u a/vpnc-script.in b/vpnc-script.in
+--- a/vpnc-script.in 2013-03-03 13:55:16.000000000 +0100
++++ b/vpnc-script.in 2013-03-03 13:56:11.000000000 +0100
+@@ -116,7 +116,7 @@
+
+ if [ -n "$IPROUTE" ]; then
+ fix_ip_get_output () {
+- sed 's/cache//;s/metric \?[0-9]\+ [0-9]\+//g;s/hoplimit [0-9]\+//g'
++ sed 's/cache//;s/metric \?[0-9]\+ [0-9]\+//g;s/hoplimit [0-9]\+//g;s/ipid 0x....//g'
+ }
+
+ set_vpngateway_route() {
diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index 608e63c7c6..ea1c21716a 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -31,7 +31,7 @@
(version "4.0.3")
(source (origin
(method url-fetch)
- (uri (string-append "http://ftp.gnu.org/gnu/screen/screen-"
+ (uri (string-append "mirror://gnu/screen/screen-"
version ".tar.gz"))
(sha256
(base32 "0xvckv1ia5pjxk7fs4za6gz2njwmfd54sc464n8ab13096qxbw3q"))))
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
new file mode 100644
index 0000000000..9393e1e7b4
--- /dev/null
+++ b/gnu/packages/vpn.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages vpn)
+ #:use-module ((guix licenses)
+ #:renamer (symbol-prefix-proc 'license:))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages perl))
+
+(define-public vpnc
+ (package
+ (name "vpnc")
+ (version "0.5.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-"
+ version ".tar.gz"))
+ (sha256 (base32
+ "1128860lis89g1s21hqxvap2nq426c9j4bvgghncc1zj0ays7kj6"))))
+ (build-system gnu-build-system)
+ (inputs `(("libgcrypt" ,libgcrypt)
+ ("perl" ,perl)
+ ("patch/script"
+ ,(search-patch "vpnc-script.patch"))))
+ (arguments
+ `(#:tests? #f ; there is no check target
+ #:patches (list (assoc-ref %build-inputs
+ "patch/script"))
+ #:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("PREFIX=/usr/local") (string-append "PREFIX=" out)))
+ (substitute* "Makefile"
+ (("ETCDIR=/etc/vpnc") (string-append "ETCDIR=" out "/etc/vpnc")))))
+ %standard-phases)))
+ (synopsis "vpnc, a client for cisco vpn concentrators")
+ (description
+ "vpnc is a VPN client compatible with Cisco's EasyVPN equipment.
+It supports IPSec (ESP) with Mode Configuration and Xauth. It supports only
+shared-secret IPSec authentication with Xauth, AES (256, 192, 128), 3DES,
+1DES, MD5, SHA1, DH1/2/5 and IP tunneling. It runs entirely in userspace.
+Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
+ (license license:gpl2+) ; some file are bsd-2, see COPYING
+ (home-page "http://www.unix-ag.uni-kl.de/~massar/vpnc/")))
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 1d7060a044..b3c5f7d512 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -26,7 +26,8 @@
#:renamer (symbol-prefix-proc 'license:))
#:use-module (guix packages)
#:use-module (guix download)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (guix build-system perl))
(define-public expat
(package
@@ -90,3 +91,34 @@ things the parser might find in the XML document (like start tags).")
"Libxslt is an XSLT C library developed for the GNOME project. It is
based on libxml for XML parsing, tree manipulation and XPath support.")
(license license:x11)))
+
+(define-public perl-xml-parser
+ (package
+ (name "perl-xml-parser")
+ (version "2.41")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MS/MSERGEANT/XML-Parser-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1sadi505g5qmxr36lgcbrcrqh3a5gcdg32b405gnr8k54b6rg0dl"))))
+ (build-system perl-build-system)
+ (arguments `(#:make-maker-flags
+ (let ((expat (assoc-ref %build-inputs "expat")))
+ (list (string-append "EXPATLIBPATH=" expat "/lib")
+ (string-append "EXPATINCPATH=" expat "/include")))))
+ (inputs `(("expat" ,expat)))
+ (license (package-license perl))
+ (synopsis "Perl bindings to the Expat XML parsing library")
+ (description
+ "This module provides ways to parse XML documents. It is built on top of
+XML::Parser::Expat, which is a lower level interface to James Clark's expat
+library. Each call to one of the parsing methods creates a new instance of
+XML::Parser::Expat which is then used to parse the document. Expat options
+may be provided when the XML::Parser object is created. These options are
+then passed on to the Expat object on each parse call. They can also be given
+as extra arguments to the parse methods, in which case they override options
+given at XML::Parser creation time.")
+ (home-page "http://search.cpan.org/~toddr/XML-Parser-2.41/Parser.pm")))