summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 1c5b195310..71bd94e8ad 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -26,6 +26,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages doxygen)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages gperf)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages perl)
@@ -229,3 +230,33 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
(description "Libabw is a library that parses the file format of
AbiWord documents.")
(license mpl2.0)))
+
+(define-public libcdr
+ (package
+ (name "libcdr")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
+ name "-" version ".tar.xz"))
+ (sha256 (base32
+ "07yzb1yr5kzv0binzj5swz3zzay2gw3xb0fbkc2zwdssgrkf19nh"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)
+ ("icu4c" ,icu4c)
+ ("lcms" ,lcms)
+ ("librevenge" ,librevenge)
+ ("zlib" ,zlib)))
+ (arguments
+ ;; avoid triggering a build failure due to warnings
+ `(#:configure-flags '("--disable-werror")))
+ (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libcdr")
+ (synopsis "Library for parsing the CorelDRAW format")
+ (description "Libcdr is a library that parses the file format of
+CorelDRAW documents of all versions.")
+ (license mpl2.0)))