summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bfc7af8f83..543f25848a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9124,14 +9124,18 @@ applications.")
(arguments
`(#:configure-flags
(list (string-append "--zmq=" (assoc-ref %build-inputs "zeromq")))
- ;; FIXME: You must build pyzmq with 'python setup.py build_ext
- ;; --inplace' for 'python setup.py test' to work.
- #:tests? #f))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ ;; Cython extensions have to be built before running the tests.
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
(inputs
`(("zeromq" ,zeromq)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("python-nose" ,python-nose)))
+ ("python-cython" ,python-cython)
+ ("python-pytest" ,python-pytest)))
(home-page "https://github.com/zeromq/pyzmq")
(synopsis "Python bindings for 0MQ")
(description