summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 991fa24697..a409f9cf21 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2016 Rodger Fox <thylakoid@openmailbox.org>
+;;; Copyright © 2016 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1917,3 +1918,36 @@ Catan. It can be played on a local network, on the internet, and with AI
players.")
(home-page "http://pio.sourceforge.net/")
(license license:gpl2+)))
+
+(define-public desmume
+ (package
+ (name "desmume")
+ (version "0.9.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/desmume/desmume/"
+ version "/desmume-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15l8wdw3q61fniy3h93d84dnm6s4pyadvh95a0j6d580rjk4pcrs"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; Enable support for WiFi and microphone.
+ `(#:configure-flags '("--enable-wifi"
+ "--enable-openal")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("zlib" ,zlib)
+ ("sdl" ,sdl)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+-2)
+ ("glu" ,glu)))
+ (home-page "http://desmume.org/")
+ (synopsis "Nintendo DS emulator")
+ (description
+ "DeSmuME is an emulator for the Nintendo DS handheld gaming console.")
+ (license license:gpl2)))