summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d59d8482eb..781074ed7c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3767,6 +3767,8 @@ Widgets, and allows users to create more.")
(chdir #$(string-append "../" (package-name this-package)
"-" (package-version this-package)))
(invoke "python3" "run_tests.py" "-a")))))))
+ (native-inputs
+ (list python swig xorg-server-for-tests))
(inputs
(list sdl2
sdl2-image
@@ -3780,10 +3782,6 @@ Widgets, and allows users to create more.")
fifechan
swig
python))
- (native-inputs
- `(("python" ,python)
- ("swig" ,swig)
- ("xvfb" ,xorg-server)))
(propagated-inputs
(list python-future))
(home-page "https://www.fifengine.net/")