summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lxqt.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index fcccf669e4..c0a948db3c 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -376,7 +376,6 @@ the operating system LXQt is running on.")
(inputs
`(("eudev" ,eudev)
("kwindowsystem" ,kwindowsystem)
- ("libkscreen" ,libkscreen)
("liblxqt" ,liblxqt)
("libqtxdg" ,libqtxdg)
("libxcursor" ,libxcursor)
@@ -392,6 +391,10 @@ the operating system LXQt is running on.")
`(("pkg-config" ,pkg-config)
("lxqt-build-tools" ,lxqt-build-tools)
("qttools" ,qttools)))
+ ;; XXX: This is a workaround so libkscreen can find the backends as we
+ ;; dont have a way specify them. We may want to patch like Nix does.
+ (propagated-inputs
+ `(("libkscreen" ,libkscreen)))
(arguments
'(#:tests? #f ; no tests
#:phases