summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c0ad85cf20..3c46102da1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8681,19 +8681,18 @@ CloudFront content delivery network.")
(inputs
`(("pkg-config" ,pkg-config)))
(arguments
- `(;; Tests fail with "ValueError: _type_ 'v' not supported" on Python 3,
- ;; and on Python 2 they need the dl module deprecated since Python 2.6.
- #:tests? #f
- ;; Hard-code the path to pkg-config.
- #:phases
+ `(#:phases
(modify-phases %standard-phases
- (add-before
- 'build 'patch
- (lambda _
- (substitute* "pkgconfig/pkgconfig.py"
- (("cmd = 'pkg-config")
- (string-append "cmd = '" (which "pkg-config"))))
- #t)))))
+ (add-before 'build 'patch
+ ;; Hard-code the path to pkg-config.
+ (lambda _
+ (substitute* "pkgconfig/pkgconfig.py"
+ (("cmd = 'pkg-config")
+ (string-append "cmd = '" (which "pkg-config"))))
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "nosetests" "test.py"))))))
(home-page "https://github.com/matze/pkgconfig")
(synopsis "Python interface for pkg-config")
(description "This module provides a Python interface to pkg-config. It