summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm42
-rw-r--r--gnu/packages/cran.scm27
-rw-r--r--gnu/packages/llvm.scm10
3 files changed, 78 insertions, 1 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 59b921af82..4d3f86bfd3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5111,6 +5111,48 @@ includes methods formerly found in the scran package, and the new fast and
comprehensive scDblFinder method.")
(license license:gpl3)))
+(define-public r-scmap
+ (package
+ (name "r-scmap")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "scmap" version))
+ (sha256
+ (base32 "0pfwaa9pgml11b84rpf7afdkmg8kxb4srgpc56571vaz388xrv7l"))))
+ (properties `((upstream-name . "scmap")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biobase
+ r-biocgenerics
+ r-dplyr
+ r-e1071
+ r-ggplot2
+ r-googlevis
+ r-matrixstats
+ r-proxy
+ r-randomforest
+ r-rcpp
+ r-rcpparmadillo
+ r-reshape2
+ r-s4vectors
+ r-singlecellexperiment
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/hemberg-lab/scmap")
+ (synopsis "Tool for unsupervised projection of single cell RNA-seq data")
+ (description
+ "@dfn{Single-cell RNA-seq} (scRNA-seq) is widely used to investigate the
+composition of complex tissues since the technology allows researchers to
+define cell-types using unsupervised clustering of the transcriptome.
+However, due to differences in experimental methods and computational
+analyses, it is often challenging to directly compare the cells identified in
+two different experiments. @code{scmap} is a method for projecting cells from
+a scRNA-seq experiment onto the cell-types or individual cells identified in a
+different experiment.")
+ (license license:gpl3)))
+
(define-public r-seqlogo
(package
(name "r-seqlogo")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 61a1b055b9..5a8285b342 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -425,6 +425,33 @@ Distance (EMD).")
(description "This package lets you manage Google Drive files from R.")
(license license:expat)))
+(define-public r-googlevis
+ (package
+ (name "r-googlevis")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "googleVis" version))
+ (sha256
+ (base32 "1s82xcs6zrlmnhay764bspzwvabfyi35nq6fwdrrk3v79q13c5jz"))))
+ (properties `((upstream-name . "googleVis")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-jsonlite))
+ (native-inputs (list r-knitr))
+ (home-page "https://mages.github.io/googleVis/")
+ (synopsis "R interface to Google Charts")
+ (description
+ "The @code{googleVis} package provides an interface between R and the Google
+Charts API. Google Charts offer interactive charts which can be embedded into
+web pages. The functions of the @code{googleVis} package allow the user to
+visualise data stored in R data frames with Google Charts without uploading
+the data to Google. The output of a @code{googleVis} function is HTML code
+that contains the data and references to JavaScript functions hosted by
+Google. @code{googleVis} makes use of the internal R HTTP server to display
+the output locally.")
+ (license license:gpl2+)))
+
(define-public r-guix-install
(package
(name "r-guix-install")
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index aedf039ff4..d3b16f2759 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -216,7 +216,15 @@ given PATCHES. When TOOLS-EXTRA is given, it must point to the
;; Use a sane default include directory.
(string-append "-DC_INCLUDE_DIRS="
(assoc-ref %build-inputs "libc")
- "/include"))
+ "/include")
+ ,@(if (target-riscv64?)
+ (list "-DLIBOMP_LIBFLAGS=-latomic"
+ "-DCMAKE_SHARED_LINKER_FLAGS=-latomic")
+ `()))
+
+ ,@(if (target-riscv64?)
+ `(#:make-flags '("LDFLAGS=-latomic"))
+ '())
;; Don't use '-g' during the build to save space.
#:build-type "Release"