summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/c.scm28
-rw-r--r--gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch13
2 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index cd31c97285..c6399280f6 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -834,3 +834,31 @@ authentication.")
Service (S3) protocol for object storage.")
(home-page "https://github.com/awslabs/aws-c-s3")
(license license:asl2.0)))
+
+(define-public aws-c-mqtt
+ (package
+ (name "aws-c-mqtt")
+ (version "0.7.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qgblakp9n281z5w1kmmy9sjiz6s44kg487l76w7p43p1dp7s401"))
+ (patches (search-patches "aws-c-mqtt-cmake-prefix.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("aws-c-http" ,aws-c-http)
+ ("aws-c-io" ,aws-c-io)))
+ (synopsis "Amazon Web Services MQTT library")
+ (description
+ "This library provides a C99 implementation of the Message Queuing
+Telemetry Transport (MQTT) publish-subscribe messaging protocol.")
+ (home-page "https://github.com/awslabs/aws-c-mqtt")
+ (license license:asl2.0)))
diff --git a/gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch b/gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch
new file mode 100644
index 0000000000..987024b57c
--- /dev/null
+++ b/gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,6 +7,10 @@ if (POLICY CMP0069)
+ cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
+ endif()
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()