summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a9ae66d588..6fcb0fceee 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1347,6 +1347,40 @@ before (or after)\".")
(description "This package provides various examples.")
(license license:expat))))
+;; ExproniconLite.jl is autogenerated from this package.
+(define-public julia-expronicon
+ (package
+ (name "julia-expronicon")
+ (version "0.6.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Roger-luo/Expronicon.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h8aaynqlxrkn8575k5vqmhzil4vvxchhf0bcxa6zwawp558gj2y"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-network-tests
+ (lambda _
+ (substitute* "test/runtests.jl"
+ ;; This test tries to access the Julia package registry.
+ ((".*expand\\.jl.*") "")))))))
+ (propagated-inputs
+ `(("julia-mlstyle" ,julia-mlstyle)))
+ (native-inputs
+ `(("julia-documenter" ,julia-documenter)))
+ (home-page "https://expronicon.rogerluo.dev/dev/")
+ (synopsis "Collective tools for metaprogramming on Julia Expr")
+ (description "This package provides a collection of tools for
+metaprogramming on Julia Expr, the meta programming standard library for
+@code{MLStyle}.")
+ (license license:expat)))
+
(define-public julia-exprtools
(package
(name "julia-exprtools")