summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/libreoffice.scm3
-rw-r--r--gnu/packages/patches/libreoffice-boost.patch17
2 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 2824d87fc6..b047c34a0b 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -997,7 +997,8 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
(sha256
(base32
"1dsd0gynjf7d6412dd2sx70xa2s8kld7ibyjdkwg5w9hhi2zxw2f"))))
- (search-patches "libreoffice-icu.patch"
+ (search-patches "libreoffice-boost.patch"
+ "libreoffice-icu.patch"
"libreoffice-glm.patch")))
(modules '((guix build utils)))
(snippet
diff --git a/gnu/packages/patches/libreoffice-boost.patch b/gnu/packages/patches/libreoffice-boost.patch
new file mode 100644
index 0000000000..b50664226b
--- /dev/null
+++ b/gnu/packages/patches/libreoffice-boost.patch
@@ -0,0 +1,17 @@
+Fix compatibility with newer Boost.
+
+Extracted from this upstream commit:
+https://cgit.freedesktop.org/libreoffice/core/commit/?id=23a8d5ffbbe58761b89f590f0735abccd69a3681
+
+diff --git a/sfx2/source/appl/shutdownicon.cxx b/sfx2/source/appl/shutdownicon.cxx
+--- a/sfx2/source/appl/shutdownicon.cxx
++++ b/sfx2/source/appl/shutdownicon.cxx
+@@ -144,7 +144,7 @@ bool LoadModule()
+ #endif // ENABLE_QUICKSTART_APPLET
+ }
+ assert(!boost::logic::indeterminate(loaded));
+- return loaded;
++ return bool(loaded);
+ }
+
+ }