summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a164048641..2a982f417c 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5163,7 +5163,16 @@ into your tests. It automatically starts up a HTTP server in a separate thread
(file-name (git-file-name name version))
(sha256
(base32
- "12ilmjma6vmlm2kl23fx5pbi226x098gljgxpx3h2kmq8pg2lm28"))))
+ "12ilmjma6vmlm2kl23fx5pbi226x098gljgxpx3h2kmq8pg2lm28"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; There are signedness errors that trigger on 32-bit
+ ;; platforms that trigger, and '-Werror' leads to build
+ ;; failures.
+ (substitute* "Makefile"
+ (("-Werror") ""))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"