summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 46ce0dde40..176bbb9416 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -341,8 +341,7 @@ data types.")
(define-public python-3.7
(package (inherit python-2)
(name "python")
- (version "3.7.0")
- (replacement python-3/fixed)
+ (version "3.7.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
@@ -355,7 +354,7 @@ data types.")
(patch-flags '("-p0"))
(sha256
(base32
- "0j9mic5c9lbd2b20wka7hily7szz740wy9ilfrczxap63rnrk0h3"))
+ "0v9x4h22rh5cwpsq1mwpdi3c9lc9820lzp2nmn9g20llij72nzps"))
(snippet
'(begin
(for-each delete-file
@@ -414,14 +413,6 @@ data types.")
;; Current 3.x version.
(define-public python-3 python-3.7)
-(define python-3/fixed
- (package
- (inherit python-3)
- (source (origin
- (inherit (package-source python-3))
- (patches (append (origin-patches (package-source python-3))
- (search-patches "python-CVE-2018-14647.patch")))))))
-
;; Current major version.
(define-public python python-3)