summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/inkscape.scm21
-rw-r--r--gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch24
2 files changed, 7 insertions, 38 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 46c8c4cc34..8747218e54 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -120,17 +120,15 @@ as the native format.")
(define-public inkscape-1.1
(package
(name "inkscape")
- (version "1.1")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://media.inkscape.org/dl/"
"resources/file/"
"inkscape-" version ".tar.xz"))
- (patches (search-patches "inkscape-1.1-fix-build-witch-gcc7.5.patch"))
(sha256
- (base32
- "1rlm2wqg8bgdxkdvnadh49wfp0mrbrk7d8n4vdcjyw6z7z7firki"))
+ (base32 "1bvqg5xfs3m6r7qfdhmgzwhd1hx8wvg3nhvhmalwzcdm6ffhpjmf"))
(modules '((guix build utils)
(ice-9 format)))
(snippet
@@ -211,8 +209,7 @@ endif()~%~%"
;; Lift the requirement on the double-conversion library, as
;; it is only needed by lib2geom, which is now unbundled.
(substitute* "CMakeScripts/DefineDependsandFlags.cmake"
- ((".*find_package\\(DoubleConversion.*") ""))
- #t))))
+ ((".*find_package\\(DoubleConversion.*") ""))))))
(build-system cmake-build-system)
(arguments
`(#:tests? #t
@@ -227,8 +224,7 @@ endif()~%~%"
(add-after 'unpack 'patch-icon-cache-generator
(lambda _
(substitute* "share/icons/application/CMakeLists.txt"
- (("gtk-update-icon-cache") "true"))
- #t))
+ (("gtk-update-icon-cache") "true"))))
(add-after 'unpack 'disable-latex-export-tests
;; FIXME: For some reason the test.pdf_tex file generated by the
;; "--export-latex" lacks "some text" in its content when run in
@@ -236,14 +232,12 @@ endif()~%~%"
(lambda _
(substitute* "testfiles/cli_tests/CMakeLists.txt"
(("add_cli_test\\(export-latex")
- "message(TEST_DISABLED: export-latex"))
- #t))
+ "message(TEST_DISABLED: export-latex"))))
(add-after 'unpack 'set-home
;; Mute Inkscape warnings during tests.
(lambda _
(setenv "HOME" (getcwd))
- (format #t "ARGS is set to: ~a" (getenv "ARGS"))
- #t))
+ (format #t "ARGS is set to: ~a" (getenv "ARGS"))))
;; Move the check phase after the install phase, as when run in the
;; tests, Inkscape relies on files that are not yet installed, such
;; as the "share/inkscape/ui/units.xml" file.
@@ -259,8 +253,7 @@ endif()~%~%"
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(wrap-program (string-append out "/bin/inkscape")
- `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))))
- #t)))))
+ `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))))))))
(inputs
`(("aspell" ,aspell)
("autotrace" ,autotrace)
diff --git a/gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch b/gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch
deleted file mode 100644
index bd7b01f856..0000000000
--- a/gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 0ae15d7e89b984f72780ff7afa8e57dd6ae7765a Mon Sep 17 00:00:00 2001
-From: "Boris A. Dekshteyn" <boris.dekshteyn@gmail.com>
-Date: Mon, 14 Jun 2021 23:52:16 +1200
-Subject: [PATCH] Fix build witch GCC@7.5.
-
----
- src/object/sp-use-reference.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/object/sp-use-reference.h b/src/object/sp-use-reference.h
-index 5958632059..f07c2a3721 100644
---- a/src/object/sp-use-reference.h
-+++ b/src/object/sp-use-reference.h
-@@ -14,6 +14,7 @@
-
- #include "sp-item.h"
- #include "uri-references.h"
-+#include "display/curve.h"
-
- #include <memory>
-
---
-2.32.0
-