summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mpi.scm2
-rw-r--r--gnu/packages/patches/openmpi-mtl-priorities.patch (renamed from gnu/packages/patches/openmpi-psm2-priority.patch)14
2 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 9f6597c6b3..45941df0b0 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -179,7 +179,7 @@ bind processes, and much more.")
"/downloads/openmpi-" version ".tar.bz2"))
(sha256
(base32 "0ms0zvyxyy3pnx9qwib6zaljyp2b3ixny64xvq3czv3jpr8zf2wh"))
- (patches (search-patches "openmpi-psm2-priority.patch"))))
+ (patches (search-patches "openmpi-mtl-priorities.patch"))))
(build-system gnu-build-system)
(inputs
`(("hwloc" ,hwloc-2 "lib")
diff --git a/gnu/packages/patches/openmpi-psm2-priority.patch b/gnu/packages/patches/openmpi-mtl-priorities.patch
index d9dd558010..fd76594ddd 100644
--- a/gnu/packages/patches/openmpi-psm2-priority.patch
+++ b/gnu/packages/patches/openmpi-mtl-priorities.patch
@@ -19,3 +19,17 @@ See <https://www.mail-archive.com/users@lists.open-mpi.org/msg33581.html>.
"priority", "Priority of the PSM2 MTL component",
MCA_BASE_VAR_TYPE_INT, NULL, 0, 0,
+Likewise for PSM: we want InfiniPath to be taken care of by PSM, not by UCX,
+since UCX achieves worse performance.
+
+--- openmpi-4.0.2/ompi/mca/mtl/psm/mtl_psm_component.c
++++ openmpi-4.0.2/ompi/mca/mtl/psm/mtl_psm_component.c
+@@ -92,7 +92,7 @@ ompi_mtl_psm_component_register(void)
+
+
+ /* set priority high enough to beat ob1's default */
+- param_priority = 30;
++ param_priority = 54;
+ (void) mca_base_component_var_register (&mca_mtl_psm_component.super.mtl_version,
+ "priority", "Priority of the PSM MTL component",
+ MCA_BASE_VAR_TYPE_INT, NULL, 0, 0,