summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/c.scm8
-rw-r--r--gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch13
2 files changed, 5 insertions, 16 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 3b10579ee7..34c87c2d4b 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -605,6 +605,7 @@ with fallback to efficient C99 software implementations.")
(define-public aws-c-event-stream
(package
(name "aws-c-event-stream")
+ ; Update only when updating aws-crt-cpp.
(version "0.2.7")
(source (origin
(method git-fetch)
@@ -614,12 +615,13 @@ with fallback to efficient C99 software implementations.")
(file-name (git-file-name name version))
(sha256
(base32
- "0xwwr7gdgfrphk6j7vk12rgimfim6m4qnj6hg8hgg16cplhvsfzh"))
- (patches (search-patches "aws-c-event-stream-cmake-prefix.patch"))))
+ "0xwwr7gdgfrphk6j7vk12rgimfim6m4qnj6hg8hgg16cplhvsfzh"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
- '("-DBUILD_SHARED_LIBS=ON")))
+ (list "-DBUILD_SHARED_LIBS=ON"
+ (string-append "-DCMAKE_PREFIX_PATH="
+ (assoc-ref %build-inputs "aws-c-common")))))
(propagated-inputs
`(("aws-c-common" ,aws-c-common)
("aws-c-io" ,aws-c-io)
diff --git a/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch b/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
deleted file mode 100644
index 79655a910b..0000000000
--- a/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -3,6 +3,10 @@
- cmake_minimum_required (VERSION 3.1)
- project (aws-c-event-stream C)
-
-+if (DEFINED ENV{CMAKE_PREFIX_PATH})
-+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
-+endif()
-+
- if (DEFINED CMAKE_PREFIX_PATH)
- file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
- endif()