summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm32
1 files changed, 6 insertions, 26 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 3db4cbae2c..be6e32a61e 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2466,7 +2466,7 @@ XC-APPGROUP, XTEST.")
(define-public libevdev
(package
(name "libevdev")
- (version "1.8.0")
+ (version "1.9.1")
(source
(origin
(method url-fetch)
@@ -2474,21 +2474,10 @@ XC-APPGROUP, XTEST.")
name "-" version ".tar.xz"))
(sha256
(base32
- "04a2klvii0in9ln8r85mk2cm73jq8ry2m3yzmf2z8xyjxzjcmlr0"))))
+ "1jvsphdrs1i54ccjcn6ll26jy42am7h28lbsvwa6pmxgqm43qq7m"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--disable-static")
- #:phases (modify-phases %standard-phases
- (add-before 'configure 'pedantry
- (lambda _
- ;; XXX: libevdev includes kernel headers, which causes this
- ;; compile test to fail with:
- ;; ...-headers-4.14.67/include/asm-generic/posix_types.h:88:14:
- ;;error: ISO C90 does not support ‘long long’ [-Werror=long-long]
- (substitute* "test/Makefile.in"
- (("-pedantic -Werror -std=c89")
- "-pedantic -Werror -std=c99"))
- #t)))))
+ `(#:configure-flags '("--disable-static")))
(native-inputs `(("python" ,python)))
(home-page "https://www.freedesktop.org/wiki/Software/libevdev/")
(synopsis "Wrapper library for evdev devices")
@@ -4032,7 +4021,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.29")
+ (version "2.30")
(source
(origin
(method url-fetch)
@@ -4042,7 +4031,7 @@ extension to the X11 protocol. It includes:
".tar.bz2"))
(sha256
(base32
- "00hqc8nykvy8c09b8vab64dcd0ij3n5klxjn6rl00q7hickpah8x"))))
+ "1m4pnzlcdl6d1p7hdccpi0605zkikind00kjc5bx4gk3gd7m4nh9"))))
(build-system gnu-build-system)
(inputs
`(("libx11" ,libx11)
@@ -5461,19 +5450,10 @@ draggable titlebars and borders.")
;; This package is intended to be used when building GTK+.
;; Note: It's currently marked as "hidden" to avoid having two non-eq?
;; packages with the same name and version.
-;; TODO: Update this in the next rebuild cycle.
(define-public xorg-server-for-tests
(hidden-package
(package
- (inherit xorg-server)
- (version "1.20.7")
- (source (origin
- (inherit (package-source xorg-server))
- (uri (string-append "mirror://xorg/individual/xserver/"
- "xorg-server-" version ".tar.bz2"))
- (sha256
- (base32
- "18bfl04ihw1jr3h0fs522nnxxq5ixjay77y9dcymnkzk23q8cndx")))))))
+ (inherit xorg-server))))
(define-public xorg-server-xwayland
(package/inherit xorg-server