summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 1a425779e5..14e35d19ae 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6174,7 +6174,7 @@ programs that cannot use the window system directly.")
(define-public perl-x11-xcb
(package
(name "perl-x11-xcb")
- (version "0.18")
+ (version "0.19")
(source (origin
(method url-fetch)
(uri (string-append
@@ -6182,7 +6182,7 @@ programs that cannot use the window system directly.")
"X11-XCB-" version ".tar.gz"))
(sha256
(base32
- "1cjpghw7cnackw20lbd7yzm222kz5bnrwz52f8ay24d1f4pwrnxf"))))
+ "1rn8g0yy82v5zp12rhxic332dvqs63l7mykg028ngvccs7rllipp"))))
(build-system perl-build-system)
(arguments
'(;; Disable parallel build to prevent a race condition.
@@ -6193,8 +6193,7 @@ programs that cannot use the window system directly.")
(lambda _
(setenv "PERL5LIB"
(string-append (getcwd) ":"
- (getenv "PERL5LIB")))
- #t))
+ (getenv "PERL5LIB")))))
(add-before 'build 'patch-Makefile
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile"
@@ -6202,8 +6201,7 @@ programs that cannot use the window system directly.")
;; an error such as "XCB.so: undefined symbol: xcb_xinerama_id"
(("^LDDLFLAGS = ")
(string-append "LDDLFLAGS = "
- "-lxcb -lxcb-util -lxcb-xinerama -lxcb-icccm ")))
- #t)))
+ "-lxcb -lxcb-util -lxcb-xinerama -lxcb-icccm "))))))
;; Tests require a running X11 server.
#:tests? #f))
(native-inputs
@@ -6681,7 +6679,7 @@ output.")
(define-public console-setup
(package
(name "console-setup")
- (version "1.205")
+ (version "1.207")
(source
(origin
(method git-fetch)
@@ -6689,7 +6687,7 @@ output.")
(url "https://salsa.debian.org/installer-team/console-setup.git")
(commit version)))
(sha256
- (base32 "0sf560s14firyvzpgww79ydzc6p3jvjkbvsi8zsr5m3hr833w0ba"))
+ (base32 "0fj93apsknx3lzbi2025pzr19q1gwnim8g4007aqqkhidc1msgx5"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -6708,8 +6706,7 @@ output.")
(substitute* '("Keyboard/ckbcomp")
(("\"cat ")
(string-append "\"" (which "cat")
- " ")))
- #t))
+ " ")))))
(add-before 'build 'make-doubled-bdfs
(lambda* (#:key native-inputs inputs #:allow-other-keys)
(invoke "make" "-C" "Fonts"