summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm50
1 files changed, 8 insertions, 42 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index e912eb1be9..f7b2cd7ab4 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2466,7 +2466,7 @@ XC-APPGROUP, XTEST.")
(define-public libevdev
(package
(name "libevdev")
- (version "1.8.0")
+ (version "1.9.1")
(source
(origin
(method url-fetch)
@@ -2474,21 +2474,10 @@ XC-APPGROUP, XTEST.")
name "-" version ".tar.xz"))
(sha256
(base32
- "04a2klvii0in9ln8r85mk2cm73jq8ry2m3yzmf2z8xyjxzjcmlr0"))))
+ "1jvsphdrs1i54ccjcn6ll26jy42am7h28lbsvwa6pmxgqm43qq7m"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--disable-static")
- #:phases (modify-phases %standard-phases
- (add-before 'configure 'pedantry
- (lambda _
- ;; XXX: libevdev includes kernel headers, which causes this
- ;; compile test to fail with:
- ;; ...-headers-4.14.67/include/asm-generic/posix_types.h:88:14:
- ;;error: ISO C90 does not support ‘long long’ [-Werror=long-long]
- (substitute* "test/Makefile.in"
- (("-pedantic -Werror -std=c89")
- "-pedantic -Werror -std=c99"))
- #t)))))
+ `(#:configure-flags '("--disable-static")))
(native-inputs `(("python" ,python)))
(home-page "https://www.freedesktop.org/wiki/Software/libevdev/")
(synopsis "Wrapper library for evdev devices")
@@ -4032,7 +4021,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.29")
+ (version "2.31")
(source
(origin
(method url-fetch)
@@ -4042,7 +4031,7 @@ extension to the X11 protocol. It includes:
".tar.bz2"))
(sha256
(base32
- "00hqc8nykvy8c09b8vab64dcd0ij3n5klxjn6rl00q7hickpah8x"))))
+ "18xddaxh83zm698syh50w983jg6b7b8zgv0dfaf7ha485hgihi6s"))))
(build-system gnu-build-system)
(inputs
`(("libx11" ,libx11)
@@ -5320,8 +5309,7 @@ over Xlib, including:
(define-public xorg-server
(package
(name "xorg-server")
- (version "1.20.8")
- (replacement xorg-server/fixed)
+ (version "1.20.9")
(source
(origin
(method url-fetch)
@@ -5329,7 +5317,7 @@ over Xlib, including:
"xorg-server-" version ".tar.bz2"))
(sha256
(base32
- "0ih15m7gh1z1ly6z7g82bkni719yisqmbk61a1wgp82bxrmn8yyi"))
+ "0w9mrnffvjgmwi50kln15i8rpdskxv97r78l75wlcmg4vzhg46g2"))
(patches
(list
;; See:
@@ -5445,35 +5433,13 @@ communicates with the user via graphical controls such as buttons and
draggable titlebars and borders.")
(license license:x11)))
-(define xorg-server/fixed ; security fixes
- (package
- (inherit xorg-server)
- (version "1.20.9")
- (source
- (origin
- (inherit (package-source xorg-server))
- (uri (string-append "mirror://xorg/individual/xserver/"
- "xorg-server-" version ".tar.bz2"))
- (sha256
- (base32
- "0w9mrnffvjgmwi50kln15i8rpdskxv97r78l75wlcmg4vzhg46g2"))))))
-
;; This package is intended to be used when building GTK+.
;; Note: It's currently marked as "hidden" to avoid having two non-eq?
;; packages with the same name and version.
-;; TODO: Update this in the next rebuild cycle.
(define-public xorg-server-for-tests
(hidden-package
(package
- (inherit xorg-server)
- (version "1.20.7")
- (source (origin
- (inherit (package-source xorg-server))
- (uri (string-append "mirror://xorg/individual/xserver/"
- "xorg-server-" version ".tar.bz2"))
- (sha256
- (base32
- "18bfl04ihw1jr3h0fs522nnxxq5ixjay77y9dcymnkzk23q8cndx")))))))
+ (inherit xorg-server))))
(define-public xorg-server-xwayland
(package/inherit xorg-server