summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm221
1 files changed, 133 insertions, 88 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 077735c686..688d33fca7 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2405,7 +2405,7 @@ DRI (Direct Rendering Infrastructure) drivers.")
(define-public xev
(package
(name "xev")
- (version "1.2.3")
+ (version "1.2.4")
(source
(origin
(method url-fetch)
@@ -2415,7 +2415,7 @@ DRI (Direct Rendering Infrastructure) drivers.")
".tar.bz2"))
(sha256
(base32
- "02ddsdx138g7szhwklpbzi0cxr34871iay3k28kdcihrz8f4zg36"))))
+ "1ql592pdhddhkipkrsxn929y9l2nn02a5fh2z3dx47kmzs5y006p"))))
(build-system gnu-build-system)
(inputs
`(("libxrender" ,libxrender)
@@ -2816,10 +2816,26 @@ X server.")
X server.")
(license license:x11)))
-
-;; non-free license
-;; (define-public xf86-video-dummy
-
+(define-public xf86-video-dummy
+ (package
+ (name "xf86-video-dummy")
+ (version "0.3.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://xorg/individual/driver/"
+ "xf86-video-dummy-" version ".tar.bz2"))
+ (sha256
+ (base32 "1fcm9vwgv8wnffbvkzddk4yxrh3kc0np6w65wj8k88q7jf3bn4ip"))))
+ (build-system gnu-build-system)
+ (inputs `(("xorg-server" ,xorg-server)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "https://www.x.org/wiki/")
+ (synopsis "Dummy video driver for X server")
+ (description
+ "Virtual/offscreen frame buffer driver for the Xorg X server.")
+ ;; per https://lists.freedesktop.org/archives/xorg/2020-June/060316.html
+ (license license:x11)))
(define-public xf86-video-fbdev
(package
@@ -3529,7 +3545,7 @@ X server.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/mjanusz/v86d.git")
+ (url "https://github.com/mjanusz/v86d")
(commit (string-append name "-" version))))
(file-name (git-file-name name version))
(sha256
@@ -5299,16 +5315,15 @@ over Xlib, including:
(define-public xorg-server
(package
(name "xorg-server")
- (version "1.20.7")
+ (version "1.20.8")
(source
(origin
(method url-fetch)
- (uri (string-append
- "mirror://xorg/individual/xserver/"
- "xorg-server-" version ".tar.bz2"))
+ (uri (string-append "mirror://xorg/individual/xserver/"
+ "xorg-server-" version ".tar.bz2"))
(sha256
(base32
- "18bfl04ihw1jr3h0fs522nnxxq5ixjay77y9dcymnkzk23q8cndx"))
+ "0ih15m7gh1z1ly6z7g82bkni719yisqmbk61a1wgp82bxrmn8yyi"))
(patches
(list
;; See:
@@ -5427,10 +5442,19 @@ draggable titlebars and borders.")
;; This package is intended to be used when building GTK+.
;; Note: It's currently marked as "hidden" to avoid having two non-eq?
;; packages with the same name and version.
+;; TODO: Update this in the next rebuild cycle.
(define-public xorg-server-for-tests
(hidden-package
(package
- (inherit xorg-server))))
+ (inherit xorg-server)
+ (version "1.20.7")
+ (source (origin
+ (inherit (package-source xorg-server))
+ (uri (string-append "mirror://xorg/individual/xserver/"
+ "xorg-server-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "18bfl04ihw1jr3h0fs522nnxxq5ixjay77y9dcymnkzk23q8cndx")))))))
(define-public xorg-server-xwayland
(package
@@ -5612,17 +5636,15 @@ Intrinsics (Xt) Library.")
(define-public twm
(package
(name "twm")
- (version "1.0.10")
+ (version "1.0.11")
(source
(origin
(method url-fetch)
- (uri (string-append
- "mirror://xorg/individual/app/" name "-"
- version
- ".tar.bz2"))
+ (uri (string-append "mirror://xorg/individual/app/twm-"
+ version ".tar.xz"))
(sha256
(base32
- "1ms5cj1w3g26zg6bxdv1j9hl0pxr4300qnv003cz1q3cl7ffljb4"))))
+ "1iv8kdb18n9vk3is5fyh6l40ipq9mkgx8ppj86byf464vr1ais7l"))))
(build-system gnu-build-system)
(inputs
`(("libxt" ,libxt)
@@ -6249,7 +6271,7 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "2.5.3")
+ (version "4.0.2")
(source
(origin
(method url-fetch)
@@ -6257,85 +6279,108 @@ basic eye-candy effects.")
version ".tar.xz"))
(sha256
(base32
- "1ys35lj28903alccks9p055psy1fsk1nxi8ncchvw8bfxkkkvbys"))))
+ "1cs39jzi59hkl421xmhi549ndmdfzkg0ap45f4nlsn9zr9zwmp3x"))
+ (patches (search-patches "xpra-4.0.1-systemd-run.patch"))))
(build-system python-build-system)
- (inputs `(("ffmpeg" ,ffmpeg)
- ("flac" ,flac)
- ("gtk+-2" ,gtk+-2) ;; no full GTK3 support yet
+ ;; see also http://xpra.org/trac/wiki/Dependencies
+ (inputs `(
+ ;; Essential dependencies.
("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libvpx" ,libvpx)
- ("libx264" ,libx264)
- ("libxcomposite" ,libxcomposite)
- ("libxdamage" ,libxdamage)
- ("libxi" ,libxi)
- ("libxkbfile" ,libxkbfile)
+ ("libwebp" ,libwebp)
+ ("ffmpeg" ,ffmpeg)
+ ("libx11" ,libx11)
("libxrandr" ,libxrandr)
("libxtst" ,libxtst)
- ("lzo" ,lzo)
- ("python2-cryptography" ,python2-cryptography)
- ("python2-dbus" ,python2-dbus)
- ("python2-lz4" ,python2-lz4)
- ("python2-lzo" ,python2-lzo)
- ("python2-netifaces" ,python2-netifaces)
- ("python2-numpy" ,python2-numpy)
- ("python2-pillow" ,python2-pillow)
- ("python2-pycairo" ,python2-pycairo)
- ("python2-pycrypto" ,python2-pycrypto)
- ("python2-pygobject" ,python2-pygobject)
- ("python2-pyopengl" ,python2-pyopengl)
- ("python2-pyopengl-accelerate" ,python2-pyopengl-accelerate)
- ("python2-pygtk" ,python2-pygtk)
- ("python2-rencode" ,python2-rencode)
- ("xorg-server" ,xorg-server)))
+ ("libxfixes" ,libxfixes)
+ ("libxkbfile" ,libxkbfile)
+ ("libxcomposite" ,libxcomposite)
+ ("libxdamage" ,libxdamage)
+ ("libxext" ,libxext)
+ ("gtk+" ,gtk+)
+ ("python-pycairo" ,python-pycairo)
+ ("python-pygobject" ,python-pygobject)
+ ("xauth" ,xauth)
+ ("xorg-server" ,xorg-server)
+ ("xf86-video-dummy" ,xf86-video-dummy)
+ ("xf86-input-mouse" ,xf86-input-mouse)
+ ("xf86-input-keyboard" ,xf86-input-keyboard)
+ ("python-pillow" ,python-pillow)
+ ;; Optional dependencies.
+ ("python-rencode" ,python-rencode) ; For speed.
+ ("python-numpy", python-numpy)
+ ("python-pyopengl" ,python-pyopengl) ; Drawing acceleration.
+ ("python-pyopengl-accelerate" ,python-pyopengl-accelerate) ; Same.
+ ("python-paramiko" ,python-paramiko) ; Tunneling over SSH.
+ ("python-dbus" ,python-dbus) ; For desktop notifications.
+ ("dbus" ,dbus) ; For dbus-launch command.
+ ("python-lz4" ,python-lz4) ; Faster compression than zlib.
+ ("python-netifaces" ,python-netifaces)))
(native-inputs `(("pkg-config" ,pkg-config)
- ("python2-cython" ,python2-cython)))
+ ("python-cython" ,python-cython)))
(arguments
- `(#:python ,python-2 ;; no full Python 3 support yet
- #:configure-flags '("--with-tests"
- "--with-bundle_tests"
- "--without-Xdummy" ;; We use Xvfb instead.
- "--without-Xdummy_wrapper"
- "--without-strict")
+ `(#:configure-flags '("--without-Xdummy"
+ "--without-Xdummy_wrapper"
+ "--with-opengl"
+ "--without-debug"
+ "--without-strict") ; Ignore compiler warnings.
#:modules ((guix build python-build-system)
(guix build utils))
-
+ #:tests? #f ; Do not run test-cases. This would rebuild all modules and
+ ; they seem to require python2.
#:phases
(modify-phases %standard-phases
+ ;; built by 'install phase
(delete 'build)
- (delete 'check) ;; There's no test suite at the moment.
-
- ;; Remove BUILD_CPU, BUILD_DATE, BUILD_TIME from build info to
- ;; prevent deterministic issues. Also correct some directories and
- ;; use the xvfb binary instead of xorg-server (which doesn't seem to
- ;; work).
- (add-before 'install 'remove-timestamps&set-file-names
+ (add-before 'install 'fix-paths
(lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "add_build_info.py"
- ((".*\"BUILD_CPU\", get_cpuinfo.*") ""))
- (substitute* "add_build_info.py"
- ((".*\"BUILD_DATE\", datetime.*") ""))
- (substitute* "add_build_info.py"
- ((".*\"BUILD_TIME\", datetime.*") ""))
- (substitute* "setup.py"
- (("/etc/init.d/")
- (string-append (assoc-ref outputs "out")
- "/etc/init.d/")))
- (substitute* "setup.py"
- (("/usr/lib/")
- (string-append (assoc-ref outputs "out") "/lib/")))
- ;; Use Xvfb with '-nolisten local' to disable abstract X11 sockets.
- (substitute* "./xpra/scripts/config.py"
- ((":.*join.*xvfb.*")
- (string-append ": \"" (assoc-ref inputs "xorg-server")
- "/bin/Xvfb +extension Composite"
- " -screen 0 5760x2560x24+32 -dpi 96 -nolisten"
- " tcp -nolisten local -noreset -auth"
- " $XAUTHORITY\",\n")))
+ ;; Fix binary paths.
+ (substitute* '("xpra/scripts/config.py" "xpra/x11/vfb_util.py")
+ (("\"Xvfb\"")
+ (string-append "\"" (assoc-ref inputs "xorg-server") "/bin/Xvfb\""))
+ (("\"Xorg\"")
+ (string-append "\"" (assoc-ref inputs "xorg-server") "/bin/Xorg\""))
+ (("\"xauth\"")
+ (string-append "\"" (assoc-ref inputs "xauth") "/bin/xauth\"")))
+ ;; Fix directory of config files.
+ (substitute* '("xpra/scripts/config.py" "xpra/platform/xposix/paths.py")
+ (("\"/etc/xpra/?\"")
+ (string-append "\"" (assoc-ref outputs "out") "/etc/xpra/\"")))
+ ;; XXX: Stolen from (gnu packages linux)
+ (define (append-to-file name body)
+ (let ((file (open-file name "a")))
+ (display body file)
+ (close-port file)))
+ ;; Add Xorg module paths.
+ (append-to-file
+ "etc/xpra/xorg.conf"
+ (string-append "\nSection \"Files\"\nModulePath \""
+ (assoc-ref inputs "xf86-video-dummy") "/lib/xorg/modules,"
+ (assoc-ref inputs "xf86-input-mouse") "/lib/xorg/modules,"
+ (assoc-ref inputs "xf86-input-keyboard") "/lib/xorg/modules,"
+ (assoc-ref inputs "xorg-server") "/lib/xorg/modules\"\n"
+ "EndSection\n\n"))
+ (substitute* '("xpra/scripts/config.py"
+ "etc/xpra/conf.d/60_server.conf.in"
+ "unittests/unit/server/mixins/notification_test.py")
+ ;; The trailing -- is intentional, so we only replace it inside
+ ;; a command line.
+ (("dbus-launch --")
+ (string-append (assoc-ref inputs "dbus") "/bin/dbus-launch --")))
+ ;; /run/user does not exist on guix system
(substitute* "./xpra/scripts/config.py"
(("socket-dir.*: \"\",")
"socket-dir\" : \"~/.xpra\","))
- #t)))))
+ #t))
+ ;; GTK3 will not be found, if GI can’t find its typelibs.
+ (add-after
+ 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/xpra")))
+ ;; XXX: only export typelibs in inputs
+ (wrap-program prog
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t))))))
(home-page "https://www.xpra.org/")
(synopsis "Remote access to individual applications or full desktops")
(description "Xpra is a persistent remote display server and client for
@@ -6604,15 +6649,15 @@ output.")
(define-public console-setup
(package
(name "console-setup")
- (version "1.195")
+ (version "1.196")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://salsa.debian.org/installer-team/console-setup.git")
- (commit "38512eb9a97f57ead1f87f6aee6df455f721c645"))) ; no tag
+ (commit version)))
(sha256
- (base32 "0d0xagigs5k3appzz5lzxdjncvnkgz4amz6ks7imiq8kkjixvmfy"))
+ (base32 "0c79rycgpna8910as6blw3z3sajzzakz4qlvr6js2yr8zq2d0ylg"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -6687,7 +6732,7 @@ Thai).")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/eworm-de/xcur2png.git")
+ (url "https://github.com/eworm-de/xcur2png")
(commit version)))
(file-name (git-file-name name version))
(sha256