summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index a05a4ba6e6..71d8e83fa4 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5764,6 +5764,12 @@ programs that cannot use the window system directly.")
#:parallel-build? #f
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'set-perl-search-path
+ (lambda _
+ (setenv "PERL5LIB"
+ (string-append (getcwd) ":"
+ (getenv "PERL5LIB")))
+ #t))
(add-before 'build 'patch-Makefile
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile"