summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm43
1 files changed, 30 insertions, 13 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 597e0b86b6..78d6f3822b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2015 Cyrill Schenkel <cyrill.schenkel@gmail.com>
-;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -2143,8 +2143,15 @@ emulate a TI-30 or an HP-10C.")
"https://xcb.freedesktop.org/dist/xcb-proto-"
version ".tar.xz"))
(sha256
- (base32
- "01d62r286yfc3rpz714nqdgkl0wk9j0wqkd4ylas1d7r4vmkqshq"))))
+ (base32
+ "01d62r286yfc3rpz714nqdgkl0wk9j0wqkd4ylas1d7r4vmkqshq"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; fractions.gcd has been deprecated since python-3.5.
+ (substitute* "xcbgen/align.py"
+ (("from fractions import gcd") "from math import gcd"))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config) ("python" ,python-minimal-wrapper)))
@@ -4733,9 +4740,13 @@ cannot be adequately worked around on the client side of the wire.")
(base32
"0azqxllcsfxc3ilhz6kwc6x7m8wc477p59ir9p0yrsldx766zbar"))))
(build-system gnu-build-system)
+ (outputs '("out" "doc")) ;man pages represent 40% of the total
(arguments
`(#:configure-flags
(list "--disable-static"
+ (string-append "--mandir="
+ (assoc-ref %outputs "doc")
+ "/share/man")
;; Disable zero malloc check that fails when cross-compiling.
,@(if (%current-target-system)
'("--disable-malloc0returnsnull")
@@ -5148,8 +5159,12 @@ new API's in libXft, or the legacy API's in libX11.")
(base32
"0q8hz3slga3w3ch8wp0k7ay9ilhz315qnab0w1y2x9w3cf7hv8rn"))))
(build-system gnu-build-system)
+ (outputs '("out" "doc")) ;man pages represent 28% of the total
(arguments
- '(#:configure-flags '("--disable-static")))
+ '(#:configure-flags (list "--disable-static"
+ (string-append "--mandir="
+ (assoc-ref %outputs "doc")
+ "/share/man"))))
(propagated-inputs
`(("xorgproto" ,xorgproto)
("libx11" ,libx11)
@@ -5270,6 +5285,7 @@ protocol.")
(base32
"0d2chjgyn5lr9sfhacfvqgnj9l9faz11vn322a06jd6lk3dxcpm5"))))
(build-system gnu-build-system)
+ (outputs '("out" "doc")) ;5.5 MiB of man pages
(propagated-inputs
`(("libpthread-stubs" ,libpthread-stubs)
("libxau" ,libxau)
@@ -5281,8 +5297,11 @@ protocol.")
`(("pkg-config" ,pkg-config)
("python" ,python-minimal-wrapper)))
(arguments
- `(#:configure-flags '("--enable-xkb"
- "--disable-static")))
+ `(#:configure-flags (list "--enable-xkb"
+ "--disable-static"
+ (string-append "--mandir="
+ (assoc-ref %outputs "doc")
+ "/share/man"))))
(home-page "https://xcb.freedesktop.org/")
(synopsis "The X C Binding (XCB) library")
(description
@@ -5384,13 +5403,11 @@ over Xlib, including:
;; The default is to use "uname -srm", which captures the kernel
;; version and makes builds non-reproducible.
"--with-os-name=GNU"
-
- "--with-os-vendor=GuixSD" ;not strictly needed, but looks nice
-
+ "--with-os-vendor=Guix" ; not strictly needed, but looks nice
;; For the log file, etc.
"--localstatedir=/var"
- ;; For sddm
+ ;; For sddm.
"--enable-kdrive"
"--enable-xephyr")
@@ -5460,17 +5477,17 @@ draggable titlebars and borders.")
(define-public libx11
(package
(name "libx11")
- (version "1.6.10")
+ (version "1.7.0")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://xorg/individual/lib/libX11-"
+ "ftp://ftp.freedesktop.org/pub/xorg//individual/lib/libX11-"
version
".tar.bz2"))
(sha256
(base32
- "09k2pqmqbn2m1bpgl7jfxyqxaaxsnzbnp2bp8ycmqldqi5ln4j5g"))))
+ "0m6bfwllr3pq2c00l51y62yiq15kphc8dw69zf67qhwmclxzkj1n"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;8 MiB of man pages + XML