summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm80
1 files changed, 66 insertions, 14 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 1af8fed5e7..9aa65291b9 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2448,7 +2448,7 @@ including most mice, keyboards, tablets and touchscreens.")
(define-public xf86-input-libinput
(package
(name "xf86-input-libinput")
- (version "0.28.0")
+ (version "0.28.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2456,7 +2456,7 @@ including most mice, keyboards, tablets and touchscreens.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "189h8vl0005yizwrs4d0sng6j8lwkd3xi1zwqg8qavn2bw34v691"))))
+ "12yr0yki94j2416bfhmkz5jpacffm27jkra89fl7h03c0y749nls"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -2905,8 +2905,8 @@ X server.")
(define-public xf86-video-intel
- (let ((commit "d7dfab62a9853b44bbcd67dac08391d8e5114c97")
- (revision "10"))
+ (let ((commit "0932a6b37ba6d5c9e916a1cb6ab89c3205b81a0c")
+ (revision "11"))
(package
(name "xf86-video-intel")
(version (git-version "2.99.917" revision commit))
@@ -2919,7 +2919,7 @@ X server.")
(commit commit)))
(sha256
(base32
- "1vcfal4xr9q6016p28lnlyg709da6d305dysyyrj3fjp9fj48sva"))
+ "10pqxp7n53ddiypd3l1i9gkbgzdpi6rz9vksbd16biq7pbijc2xf"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(inputs `(("mesa" ,mesa)
@@ -3174,14 +3174,14 @@ This driver is intended for the spice qxl virtio device.")
(define-public xf86-video-r128
(package
(name "xf86-video-r128")
- (version "6.11.0")
+ (version "6.12.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://xorg/individual/driver/"
name "-" version ".tar.bz2"))
(sha256
(base32
- "0snvwmrh8dqyyaq7ggicym6yrsg4brygkx9156r0m095m7fp3rav"))))
+ "0mz0v5mqmmbncr2drd5zvia1fb7frz2xqwflhhqbnaxx5j48c740"))))
(build-system gnu-build-system)
(inputs `(("mesa" ,mesa)
("xorgproto" ,xorgproto)
@@ -5065,7 +5065,7 @@ over Xlib, including:
(define-public xorg-server
(package
(name "xorg-server")
- (version "1.20.1")
+ (version "1.20.3")
(source
(origin
(method url-fetch)
@@ -5074,7 +5074,7 @@ over Xlib, including:
name "-" version ".tar.bz2"))
(sha256
(base32
- "0679942x1ma2p30vlvqylpjc5v1ak1pgqysnqrj82nz7dzl9zjar"))
+ "1ph1j8gy5cazsq05krq9kppjx5v1sl75pbdka8ibxb1cq5kf8g0v"))
(patches
(list
;; See:
@@ -5453,6 +5453,58 @@ The XCB util module provides the following libraries:
"file://COPYING"
"See COPYING in the distribution."))))
+(define-public xcb-util-errors
+ (let ((commit "5d660ebe872cadcdc85de9d6f9afe05de629c030")
+ (revision "1"))
+ (package
+ (name "xcb-util-errors")
+ (version (git-version "1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://anongit.freedesktop.org/git/xcb/util-errors.git")
+ (commit commit)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12bah0iz5k6b9hwlc5zffyfg2gnrajll3gn5s8zmazgynvw72ahg"))))
+ (build-system gnu-build-system)
+ (outputs '("out"))
+ (inputs
+ `(("util-macros" ,util-macros)
+ ("xcb-proto" ,xcb-proto)))
+ (propagated-inputs
+ `(("libxcb" ,libxcb)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("python-2" ,python-2)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ ;; The default 'bootstrap' phase would run 'autogen.sh', which
+ ;; would try to run ./configure and fail due to unpatched
+ ;; shebangs.
+ (invoke "autoreconf" "-v" "--install"))))))
+ (home-page "https://cgit.freedesktop.org/xcb/util-errors/")
+ (synopsis "XCB helper library for printing information about X11 errors")
+ (description
+ "The XCB util module provides a number of libraries which sit on
+top of libxcb, the core X protocol library, and some of the extension
+libraries. These experimental libraries provide convenience functions
+and interfaces which make the raw X protocol more usable. Some of the
+libraries also provide client-side code which is not strictly part of
+the X protocol but which has traditionally been provided by Xlib.
+
+The XCB util-errors module provides a utility library that gives human
+readable names to error codes, event codes, and also to major and minor
+numbers.")
+ (license license:x11))))
(define-public xcb-util-image
(package
@@ -5752,7 +5804,7 @@ programs that cannot use the window system directly.")
(define-public perl-x11-xcb
(package
(name "perl-x11-xcb")
- (version "0.17")
+ (version "0.18")
(source (origin
(method url-fetch)
(uri (string-append
@@ -5760,7 +5812,7 @@ programs that cannot use the window system directly.")
"X11-XCB-" version ".tar.gz"))
(sha256
(base32
- "12qyf98s5hbybmh0mblpz50c00i68srq73w5rw31m2dhclj8n96q"))))
+ "1cjpghw7cnackw20lbd7yzm222kz5bnrwz52f8ay24d1f4pwrnxf"))))
(build-system perl-build-system)
(arguments
'(;; Disable parallel build to prevent a race condition.
@@ -5887,7 +5939,7 @@ Conventions Manual) and some of the @dfn{EWMH}
(add-after 'unpack 'autogen
(lambda _
(setenv "NOCONFIGURE" "t")
- (zero? (system* "sh" "autogen.sh")))))))
+ (invoke "sh" "autogen.sh"))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("autoconf" ,autoconf)
@@ -5910,7 +5962,7 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "2.4")
+ (version "2.4.2")
(source
(origin
(method url-fetch)
@@ -5918,7 +5970,7 @@ basic eye-candy effects.")
version ".tar.xz"))
(sha256
(base32
- "0blzx231sr1ri1zwzpwzf611sq9104bv3ccvnap9pbvfrc05sfwx"))))
+ "01x4ri0arfq9cn01bh80h232lsj95jp6j1zw0z0q7a6mwrw4gr6i"))))
(build-system python-build-system)
(inputs `(("ffmpeg" ,ffmpeg)
("flac" ,flac)