summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm93
1 files changed, 48 insertions, 45 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6a7849f8c6..9978480e4b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2015 Cyrill Schenkel <cyrill.schenkel@gmail.com>
-;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -29,6 +29,7 @@
;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
@@ -225,14 +226,14 @@ which can be read by any architecture.")
(define-public xorgproto
(package
(name "xorgproto")
- (version "2019.2")
+ (version "2021.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://xorg/individual/proto/"
"xorgproto-" version ".tar.bz2"))
(sha256
(base32
- "13kvir8dz9dvzhvyfndpff1z7k8h14s7kkl7mbl427andhax1v26"))))
+ "1gwz8lhvczjinndrq2jb0swfvhk7p65rprkwiqwlp132041mfl8g"))))
(build-system gnu-build-system)
(propagated-inputs
;; To get util-macros in (almost?) all package inputs.
@@ -1474,7 +1475,7 @@ treat it as part of their software base when porting.")
(define-public libxres
(package
(name "libxres")
- (version "1.2.0")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
@@ -1484,7 +1485,7 @@ treat it as part of their software base when porting.")
".tar.bz2"))
(sha256
(base32
- "1m0jr0lbz9ixpp9ihk68349q0i7ry2379lnfzdy4mrl86ijc2xgz"))))
+ "049b7dk6hx47161hg47ryjrm6pwsp27r5pby05b0wqb1pcggprmn"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-static")))
@@ -1906,7 +1907,7 @@ management to participate in an X11R6 session.")
(define-public util-macros
(package
(name "util-macros")
- (version "1.19.2")
+ (version "1.19.3")
(source
(origin
(method url-fetch)
@@ -1916,7 +1917,7 @@ management to participate in an X11R6 session.")
".tar.bz2"))
(sha256
(base32
- "04p7ydqxgq37jklnfj18b70zsifiz4h50wvrk94i2112mmv37r6p"))))
+ "0w8ryfqylprz37zj9grl4jzdsqq67ibfwq5raj7vm1i7kmp2x08g"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(arguments
@@ -2149,8 +2150,15 @@ emulate a TI-30 or an HP-10C.")
"https://xcb.freedesktop.org/dist/xcb-proto-"
version ".tar.xz"))
(sha256
- (base32
- "01d62r286yfc3rpz714nqdgkl0wk9j0wqkd4ylas1d7r4vmkqshq"))))
+ (base32
+ "01d62r286yfc3rpz714nqdgkl0wk9j0wqkd4ylas1d7r4vmkqshq"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; fractions.gcd has been deprecated since python-3.5.
+ (substitute* "xcbgen/align.py"
+ (("from fractions import gcd") "from math import gcd"))
+ #t))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config) ("python" ,python-minimal-wrapper)))
@@ -3912,7 +3920,7 @@ alternative implementations like XRandR or TwinView.")
(define xkbcomp-intermediate ;used as input for xkeyboard-config
(package
(name "xkbcomp-intermediate")
- (version "1.4.4")
+ (version "1.4.5")
(source
(origin
(method url-fetch)
@@ -3920,7 +3928,7 @@ alternative implementations like XRandR or TwinView.")
version ".tar.bz2"))
(sha256
(base32
- "0zpjkbap9160pdd6jpgb5f0yg5281w0rkkx1l0i7g887lq1ydk2r"))))
+ "0pmhshqinwqh5rip670l3szjpywky67hv232ql6gvdj489n0hlb8"))))
(build-system gnu-build-system)
(inputs
`(("xorgproto" ,xorgproto)
@@ -4049,7 +4057,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.31")
+ (version "2.33")
(source
(origin
(method url-fetch)
@@ -4059,7 +4067,7 @@ extension to the X11 protocol. It includes:
".tar.bz2"))
(sha256
(base32
- "18xddaxh83zm698syh50w983jg6b7b8zgv0dfaf7ha485hgihi6s"))))
+ "1g6kn7l0mixw50kgn7d97gwv1990c5rczr2x776q3xywss8dfzv5"))))
(build-system gnu-build-system)
(inputs
`(("libx11" ,libx11)
@@ -4763,9 +4771,13 @@ cannot be adequately worked around on the client side of the wire.")
(base32
"0azqxllcsfxc3ilhz6kwc6x7m8wc477p59ir9p0yrsldx766zbar"))))
(build-system gnu-build-system)
+ (outputs '("out" "doc")) ;man pages represent 40% of the total
(arguments
`(#:configure-flags
(list "--disable-static"
+ (string-append "--mandir="
+ (assoc-ref %outputs "doc")
+ "/share/man")
;; Disable zero malloc check that fails when cross-compiling.
,@(if (%current-target-system)
'("--disable-malloc0returnsnull")
@@ -5089,7 +5101,7 @@ an X Window System display.")
(define-public libxfixes
(package
(name "libxfixes")
- (version "5.0.3")
+ (version "6.0.0")
(source
(origin
(method url-fetch)
@@ -5099,7 +5111,7 @@ an X Window System display.")
".tar.bz2"))
(sha256
(base32
- "1miana3y4hwdqdparsccmygqr3ic3hs5jrqfzp70hvi2zwxd676y"))))
+ "0k2v4i4r24y3kdr5ici1qqhp69djnja919xfqp54c2rylm6s5hd7"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-static")))
@@ -5178,8 +5190,12 @@ new API's in libXft, or the legacy API's in libX11.")
(base32
"0q8hz3slga3w3ch8wp0k7ay9ilhz315qnab0w1y2x9w3cf7hv8rn"))))
(build-system gnu-build-system)
+ (outputs '("out" "doc")) ;man pages represent 28% of the total
(arguments
- '(#:configure-flags '("--disable-static")))
+ '(#:configure-flags (list "--disable-static"
+ (string-append "--mandir="
+ (assoc-ref %outputs "doc")
+ "/share/man"))))
(propagated-inputs
`(("xorgproto" ,xorgproto)
("libx11" ,libx11)
@@ -5300,6 +5316,7 @@ protocol.")
(base32
"0d2chjgyn5lr9sfhacfvqgnj9l9faz11vn322a06jd6lk3dxcpm5"))))
(build-system gnu-build-system)
+ (outputs '("out" "doc")) ;5.5 MiB of man pages
(propagated-inputs
`(("libpthread-stubs" ,libpthread-stubs)
("libxau" ,libxau)
@@ -5311,8 +5328,11 @@ protocol.")
`(("pkg-config" ,pkg-config)
("python" ,python-minimal-wrapper)))
(arguments
- `(#:configure-flags '("--enable-xkb"
- "--disable-static")))
+ `(#:configure-flags (list "--enable-xkb"
+ "--disable-static"
+ (string-append "--mandir="
+ (assoc-ref %outputs "doc")
+ "/share/man"))))
(home-page "https://xcb.freedesktop.org/")
(synopsis "The X C Binding (XCB) library")
(description
@@ -5414,13 +5434,11 @@ over Xlib, including:
;; The default is to use "uname -srm", which captures the kernel
;; version and makes builds non-reproducible.
"--with-os-name=GNU"
-
- "--with-os-vendor=GuixSD" ;not strictly needed, but looks nice
-
+ "--with-os-vendor=Guix" ; not strictly needed, but looks nice
;; For the log file, etc.
"--localstatedir=/var"
- ;; For sddm
+ ;; For sddm.
"--enable-kdrive"
"--enable-xephyr")
@@ -5513,18 +5531,15 @@ draggable titlebars and borders.")
(define-public libx11
(package
(name "libx11")
- (version "1.6.10")
+ (version "1.7.2")
(source
(origin
(method url-fetch)
- (uri (string-append
- "mirror://xorg/individual/lib/libX11-"
- version
- ".tar.bz2"))
+ (uri (string-append "mirror://xorg/individual/lib/libX11-"
+ version ".tar.bz2"))
(sha256
(base32
- "09k2pqmqbn2m1bpgl7jfxyqxaaxsnzbnp2bp8ycmqldqi5ln4j5g"))))
- (replacement libx11/fixed)
+ "0v7aj8q3rlchdyfwdna7n7vgpyzyir391dlv5rwy9fxagbikbyhw"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;8 MiB of man pages + XML
@@ -5552,18 +5567,6 @@ draggable titlebars and borders.")
(description "Xorg Core X11 protocol client library.")
(license license:x11)))
-(define-public libx11/fixed
- (package
- (inherit libx11)
- (version "1.7.1A")
- (source
- (origin
- (method url-fetch)
- (uri "mirror://xorg/individual/lib/libX11-1.7.1.tar.bz2")
- (sha256
- (base32
- "0isxad59hvdwggbxqqjjjg3zmih9xiq4d9mdsnqbyb2nmbg46kp6"))))))
-
;; packages of height 5 in the propagated-inputs tree
(define-public libxcursor
@@ -5607,7 +5610,7 @@ draggable titlebars and borders.")
(define-public libxt
(package
(name "libxt")
- (version "1.2.0")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
@@ -5617,7 +5620,7 @@ draggable titlebars and borders.")
".tar.bz2"))
(sha256
(base32
- "0cbqlyssr8aia88c8i7z59z9d0kp3p2hp6683xhz9ndyv8qza7dk"))
+ "0q1x7842r8rcn2m0q4q9f69h4qa097fyizs8brzx5ns62s7w1737"))
(patches (search-patches "libxt-guix-search-paths.patch"))))
(build-system gnu-build-system)
(outputs '("out"
@@ -5649,7 +5652,7 @@ draggable titlebars and borders.")
(define-public libxaw
(package
(name "libxaw")
- (version "1.0.13")
+ (version "1.0.14")
(source
(origin
(method url-fetch)
@@ -5659,7 +5662,7 @@ draggable titlebars and borders.")
".tar.bz2"))
(sha256
(base32
- "1kdhxplwrn43d9jp3v54llp05kwx210lrsdvqb6944jp29rhdy4f"))))
+ "13kg59r3086383g1dyhnwxanhp2frssh9062mrgn34nzlf7gkbkn"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-static")))