summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm28
1 files changed, 6 insertions, 22 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index f7b2cd7ab4..b1a4d4a9bd 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2017, 2018, 2020 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2015 Cyrill Schenkel <cyrill.schenkel@gmail.com>
@@ -5388,13 +5388,11 @@ over Xlib, including:
;; The default is to use "uname -srm", which captures the kernel
;; version and makes builds non-reproducible.
"--with-os-name=GNU"
-
- "--with-os-vendor=GuixSD" ;not strictly needed, but looks nice
-
+ "--with-os-vendor=Guix" ; not strictly needed, but looks nice
;; For the log file, etc.
"--localstatedir=/var"
- ;; For sddm
+ ;; For sddm.
"--enable-kdrive"
"--enable-xephyr")
@@ -5464,18 +5462,17 @@ draggable titlebars and borders.")
(define-public libx11
(package
(name "libx11")
- (version "1.6.9")
- (replacement libx11/fixed)
+ (version "1.6.12")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://xorg/individual/lib/libX11-"
+ "ftp://ftp.freedesktop.org/pub/xorg//individual/lib/libX11-"
version
".tar.bz2"))
(sha256
(base32
- "1ldyn9c6pyx54sxzaw120n3q42rqi7b503aqmyjky6fn038fiiww"))))
+ "1ivfzl1qwk8zh7gc0m5vb58gdxz11jwg7w3d356w16j1d5s2427i"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;8 MiB of man pages + XML
@@ -5503,19 +5500,6 @@ draggable titlebars and borders.")
(description "Xorg Core X11 protocol client library.")
(license license:x11)))
-(define libx11/fixed ; Fixes CVE-2020-14344
- (package
- (inherit libx11)
- (version "1.6.A")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://xorg/individual/lib/libX11-1.6.10.tar.bz2"))
- (sha256
- (base32
- "09k2pqmqbn2m1bpgl7jfxyqxaaxsnzbnp2bp8ycmqldqi5ln4j5g"))))))
-
;; packages of height 5 in the propagated-inputs tree
(define-public libxcursor