summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 348fb25581..42f2d18b83 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4556,6 +4556,36 @@ keysyms: Standard X key constants and conversion to/from keycodes.")
(license license:x11)))
+(define-public xcb-util-renderutil
+ (package
+ (name "xcb-util-renderutil")
+ (version "0.3.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://xcb.freedesktop.org/dist/" name "-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "0lkl9ij9b447c0br2qc5qsynjn09c4fdz7sd6yp7pyi8az2sb2cp"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("libxcb" ,libxcb)))
+ (inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://cgit.freedesktop.org/xcb/util-renderutil/")
+ (synopsis "SConvenience functions for the Render extension")
+ (description "The XCB util module provides a number of libraries which
+ sit on top of libxcb, the core X protocol library, and some of the
+ extension libraries. These experimental libraries provide convenience
+functions and interfaces which make the raw X protocol more usable. Some of
+the libraries also provide client-side code which is not strictly part of
+the X protocol but which has traditionally been provided by Xlib.
+
+The XCB util-renderutil module provides the following library:
+renderutil: Convenience functions for the Render extension.")
+ (license license:x11)))
+
+
(define-public xcb-util-wm
(package
(name "xcb-util-wm")