summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm208
1 files changed, 135 insertions, 73 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 3875765d25..9aa65291b9 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2447,7 +2448,7 @@ including most mice, keyboards, tablets and touchscreens.")
(define-public xf86-input-libinput
(package
(name "xf86-input-libinput")
- (version "0.28.0")
+ (version "0.28.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2455,7 +2456,7 @@ including most mice, keyboards, tablets and touchscreens.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "189h8vl0005yizwrs4d0sng6j8lwkd3xi1zwqg8qavn2bw34v691"))))
+ "12yr0yki94j2416bfhmkz5jpacffm27jkra89fl7h03c0y749nls"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -2644,33 +2645,27 @@ as USB mice.")
"xf86-video-ark is an Ark Logic video driver for the Xorg X server.")
(license license:x11)))
-;; This driver depends on XAA which has been removed from xorg-server.
-;;
-;; (define-public xf86-video-ast
-;; (package
-;; (name "xf86-video-ast")
-;; (version "0.93.10")
-;; (source
-;; (origin
-;; (method url-fetch)
-;; (uri (string-append
-;; "mirror://xorg/individual/driver/xf86-video-ast-"
-;; version
-;; ".tar.bz2"))
-;; (sha256
-;; (base32
-;; "1q64z8qqa0ix3cymqiwk1s3sphd1fvvz30lvyxhgkgciygz6dm69"))
-;; (patches (search-patches "xf86-video-ast-remove-mibstore.patch"))))
-;; (build-system gnu-build-system)
-;; (inputs `(("xorg-server" ,xorg-server)))
-;; (native-inputs `(("pkg-config" ,pkg-config)))
-;; (home-page "https://www.x.org/wiki/")
-;; (synopsis "ASpeed Technologies video driver for X server")
-;; (description
-;; "xf86-video-ast is an ASpeed Technologies video driver for the Xorg
-;; X server.")
-;; (license license:x11)))
-
+(define-public xf86-video-ast
+ (package
+ (name "xf86-video-ast")
+ (version "1.1.5")
+ (home-page "https://cgit.freedesktop.org/xorg/driver/xf86-video-ast/")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/driver/xf86-video-ast-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1pm2cy81ma7ldsw0yfk28b33h9z2hcj5rccrxhfxfgvxsiavrnqy"))))
+ (build-system gnu-build-system)
+ (inputs `(("xorg-server" ,xorg-server)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (synopsis "ASpeed Technologies video driver for X server")
+ (description
+ "xf86-video-ast is an ASpeed Technologies video driver for the Xorg
+X server.")
+ (license license:x11)))
(define-public xf86-video-ati
(package
@@ -2910,8 +2905,8 @@ X server.")
(define-public xf86-video-intel
- (let ((commit "d7dfab62a9853b44bbcd67dac08391d8e5114c97")
- (revision "10"))
+ (let ((commit "0932a6b37ba6d5c9e916a1cb6ab89c3205b81a0c")
+ (revision "11"))
(package
(name "xf86-video-intel")
(version (git-version "2.99.917" revision commit))
@@ -2924,7 +2919,7 @@ X server.")
(commit commit)))
(sha256
(base32
- "1vcfal4xr9q6016p28lnlyg709da6d305dysyyrj3fjp9fj48sva"))
+ "10pqxp7n53ddiypd3l1i9gkbgzdpi6rz9vksbd16biq7pbijc2xf"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(inputs `(("mesa" ,mesa)
@@ -3179,14 +3174,14 @@ This driver is intended for the spice qxl virtio device.")
(define-public xf86-video-r128
(package
(name "xf86-video-r128")
- (version "6.11.0")
+ (version "6.12.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://xorg/individual/driver/"
name "-" version ".tar.bz2"))
(sha256
(base32
- "0snvwmrh8dqyyaq7ggicym6yrsg4brygkx9156r0m095m7fp3rav"))))
+ "0mz0v5mqmmbncr2drd5zvia1fb7frz2xqwflhhqbnaxx5j48c740"))))
(build-system gnu-build-system)
(inputs `(("mesa" ,mesa)
("xorgproto" ,xorgproto)
@@ -3834,7 +3829,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.23.1")
+ (version "2.24")
(source
(origin
(method url-fetch)
@@ -3844,7 +3839,7 @@ extension to the X11 protocol. It includes:
".tar.bz2"))
(sha256
(base32
- "1wq27cs1c9y7d1d7zp5yhq29paj9smajdb68lyvm28d2zq2vqjra"))))
+ "1my4786pd7iv5x392r9skj3qclmbd26nqzvh2fllwkkbyj08bcci"))))
(build-system gnu-build-system)
(inputs
`(("gettext" ,gettext-minimal)
@@ -5070,7 +5065,7 @@ over Xlib, including:
(define-public xorg-server
(package
(name "xorg-server")
- (version "1.20.1")
+ (version "1.20.3")
(source
(origin
(method url-fetch)
@@ -5079,7 +5074,7 @@ over Xlib, including:
name "-" version ".tar.bz2"))
(sha256
(base32
- "0679942x1ma2p30vlvqylpjc5v1ak1pgqysnqrj82nz7dzl9zjar"))
+ "1ph1j8gy5cazsq05krq9kppjx5v1sl75pbdka8ibxb1cq5kf8g0v"))
(patches
(list
;; See:
@@ -5198,21 +5193,10 @@ draggable titlebars and borders.")
;; This package is intended to be used when building GTK+.
;; Note: It's currently marked as "hidden" to avoid having two non-eq?
;; packages with the same name and version.
-(define-public xorg-server-1.19.3
+(define-public xorg-server-for-tests
(hidden-package
(package
- (inherit xorg-server)
- (name "xorg-server")
- (version "1.19.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "mirror://xorg/individual/xserver/"
- name "-" version ".tar.bz2"))
- (sha256
- (base32
- "162s1v901djr57gxmmk4airk8hiwcz79dqyz72972x1lw1k82yk7")))))))
+ (inherit xorg-server))))
(define-public xorg-server-xwayland
(package
@@ -5238,8 +5222,7 @@ draggable titlebars and borders.")
(define-public libx11
(package
(name "libx11")
- (version "1.6.5")
- (replacement libx11-1.6.6)
+ (version "1.6.6")
(source
(origin
(method url-fetch)
@@ -5249,7 +5232,7 @@ draggable titlebars and borders.")
".tar.bz2"))
(sha256
(base32
- "0pa3cfp6h9rl2vxmkph65250gfqyki0ccqyaan6bl9d25gdr0f2d"))))
+ "0ks1mxlda7nxfmffihi15ljsn50q8dknl33i2xag8xzc80fiizk5"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;8 MiB of man pages + XML
@@ -5269,20 +5252,6 @@ draggable titlebars and borders.")
(description "Xorg Core X11 protocol client library.")
(license license:x11)))
-;; Replacement package to fix multiple security bugs:
-;; <http://seclists.org/oss-sec/2018/q3/146>.
-(define-public libx11-1.6.6
- (package
- (inherit libx11)
- (version "1.6.6")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://xorg/individual/lib/libX11-"
- version ".tar.bz2"))
- (sha256
- (base32
- "0ks1mxlda7nxfmffihi15ljsn50q8dknl33i2xag8xzc80fiizk5"))))))
-
;; packages of height 5 in the propagated-inputs tree
(define-public libxcursor
@@ -5484,6 +5453,58 @@ The XCB util module provides the following libraries:
"file://COPYING"
"See COPYING in the distribution."))))
+(define-public xcb-util-errors
+ (let ((commit "5d660ebe872cadcdc85de9d6f9afe05de629c030")
+ (revision "1"))
+ (package
+ (name "xcb-util-errors")
+ (version (git-version "1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://anongit.freedesktop.org/git/xcb/util-errors.git")
+ (commit commit)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12bah0iz5k6b9hwlc5zffyfg2gnrajll3gn5s8zmazgynvw72ahg"))))
+ (build-system gnu-build-system)
+ (outputs '("out"))
+ (inputs
+ `(("util-macros" ,util-macros)
+ ("xcb-proto" ,xcb-proto)))
+ (propagated-inputs
+ `(("libxcb" ,libxcb)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("python-2" ,python-2)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ ;; The default 'bootstrap' phase would run 'autogen.sh', which
+ ;; would try to run ./configure and fail due to unpatched
+ ;; shebangs.
+ (invoke "autoreconf" "-v" "--install"))))))
+ (home-page "https://cgit.freedesktop.org/xcb/util-errors/")
+ (synopsis "XCB helper library for printing information about X11 errors")
+ (description
+ "The XCB util module provides a number of libraries which sit on
+top of libxcb, the core X protocol library, and some of the extension
+libraries. These experimental libraries provide convenience functions
+and interfaces which make the raw X protocol more usable. Some of the
+libraries also provide client-side code which is not strictly part of
+the X protocol but which has traditionally been provided by Xlib.
+
+The XCB util-errors module provides a utility library that gives human
+readable names to error codes, event codes, and also to major and minor
+numbers.")
+ (license license:x11))))
(define-public xcb-util-image
(package
@@ -5783,7 +5804,7 @@ programs that cannot use the window system directly.")
(define-public perl-x11-xcb
(package
(name "perl-x11-xcb")
- (version "0.17")
+ (version "0.18")
(source (origin
(method url-fetch)
(uri (string-append
@@ -5791,7 +5812,7 @@ programs that cannot use the window system directly.")
"X11-XCB-" version ".tar.gz"))
(sha256
(base32
- "12qyf98s5hbybmh0mblpz50c00i68srq73w5rw31m2dhclj8n96q"))))
+ "1cjpghw7cnackw20lbd7yzm222kz5bnrwz52f8ay24d1f4pwrnxf"))))
(build-system perl-build-system)
(arguments
'(;; Disable parallel build to prevent a race condition.
@@ -5918,7 +5939,7 @@ Conventions Manual) and some of the @dfn{EWMH}
(add-after 'unpack 'autogen
(lambda _
(setenv "NOCONFIGURE" "t")
- (zero? (system* "sh" "autogen.sh")))))))
+ (invoke "sh" "autogen.sh"))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("autoconf" ,autoconf)
@@ -5941,7 +5962,7 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "2.3.3")
+ (version "2.4.2")
(source
(origin
(method url-fetch)
@@ -5949,7 +5970,7 @@ basic eye-candy effects.")
version ".tar.xz"))
(sha256
(base32
- "1azvvddjfq7lb5kmbn0ilgq2nf7pmymsc3b9lhbjld6w156qdv01"))))
+ "01x4ri0arfq9cn01bh80h232lsj95jp6j1zw0z0q7a6mwrw4gr6i"))))
(build-system python-build-system)
(inputs `(("ffmpeg" ,ffmpeg)
("flac" ,flac)
@@ -6196,3 +6217,44 @@ and embedded platforms.")
cursor to any point on the screen with a few key strokes. It also simulates
mouse click. You can do everything mouse can do with a keyboard.")
(license license:bsd-3)))
+
+(define-public transset-df
+ (package
+ (name "transset-df")
+ (version "6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://forchheimer.se/" name "/" name "-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1vnykwwrv75miigbhmcwxniw8xnhsdyzhqydip2m9crxi2lwhqs5"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'setenv
+ (lambda _
+ (setenv "CC" (which "gcc"))
+ #t))
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "transset-df" bin)
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs `(("libxcomposite" ,libxcomposite)
+ ("libxdamager" ,libxdamage)
+ ("libxrender" ,libxrender)))
+ (synopsis "Set the transparency of X11 windows")
+ (description "The @command{transset-df} command allows you to set the
+opacity of X11 windows. This patched version of X.Org's @command{transset}
+adds functionality, including: selecting window by clicking (as transset),
+selecting windows by pointing select actual focused X11 window, selecting by
+window name or id, forcing toggle, increase or decrease opacity.")
+ (home-page "http://forchheimer.se/transset-df/")
+ (license license:x11)))