summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm58
1 files changed, 34 insertions, 24 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 9743086b1e..c01d9f4dce 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2016, 2017, 2018, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Raimon Grau <raimonster@gmail.com>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
@@ -120,8 +120,8 @@ the entire document.")
(define-public expat
(package
(name "expat")
- (version "2.2.9")
(replacement expat-2.4.1)
+ (version "2.3.0")
(source (let ((dot->underscore (lambda (c) (if (char=? #\. c) #\_ c))))
(origin
(method url-fetch)
@@ -133,7 +133,7 @@ the entire document.")
"/expat-" version ".tar.xz")))
(sha256
(base32
- "1960mmgbb4cm64n1p0nz3hrs1pw03hkrfcw8prmnn4622mdrd9hy")))))
+ "1ab7fkab4wbj53xqsx2a4h5m310ak9abczjh0a2ymg73nsclz8ya")))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--disable-static")))
@@ -199,24 +199,30 @@ hierarchical form with variable field lengths.")
(base32
"07xynh8hcxb2yb1fs051xrgszjvj37wnxvxgsj10rzmqzy9y3zma"))))
(build-system gnu-build-system)
- (outputs '("out" "static"))
+ (outputs '("out" "static" "doc"))
(arguments
`(#:phases (modify-phases %standard-phases
- (add-after 'install 'move-static-libs
+ (add-after 'install 'use-other-outputs
(lambda* (#:key outputs #:allow-other-keys)
- (let ((src (string-append (assoc-ref outputs "out") "/lib"))
+ (let ((src (assoc-ref outputs "out"))
+ (doc (string-append (assoc-ref outputs "doc") "/share"))
(dst (string-append (assoc-ref outputs "static")
"/lib")))
+ (mkdir-p doc)
(mkdir-p dst)
+ (for-each (lambda (dir)
+ (rename-file (string-append src "/share/" dir)
+ (string-append doc "/" dir)))
+ '("doc" "gtk-doc"))
(for-each (lambda (ar)
(rename-file ar (string-append dst "/"
(basename ar))))
- (find-files src "\\.a$"))
+ (find-files (string-append src "/lib") "\\.a$"))
;; Remove reference to the static library from the .la
;; file such that Libtool does the right thing when both
;; the shared and static variants are available.
- (substitute* (string-append src "/libxml2.la")
+ (substitute* (string-append src "/lib/libxml2.la")
(("^old_library='libxml2.a'") "old_library=''"))
#t))))))
(home-page "http://www.xmlsoft.org/")
@@ -373,8 +379,10 @@ It uses libxml2 to access the XML files.")
(name "python-libxml2")
(source (origin
(inherit (package-source libxml2))
- (patches (cons (search-patch "python-libxml2-utf8.patch")
- (origin-patches (package-source libxml2))))))
+ (patches
+ (append (search-patches "python-libxml2-python39-compat.patch"
+ "python-libxml2-utf8.patch")
+ (origin-patches (package-source libxml2))))))
(build-system python-build-system)
(outputs '("out"))
(arguments
@@ -2567,15 +2575,18 @@ The central program included in this package is @code{onsgmls}, which replaces
(define-public python-elementpath
(package
(name "python-elementpath")
- (version "1.4.0")
+ (version "2.0.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "elementpath" version))
(sha256
(base32
- "15h7d41v48q31hzjay7qzixdv531hnga3h35hksk7x52pgqcrkz7"))))
+ "1kxx573ywqfh6j6aih2i6hhsya6kz79qq4bgz6yskwk6b18jyr8z"))))
(build-system python-build-system)
+ ;; The test suite is not run, to avoid a dependency cycle with
+ ;; python-xmlschema.
+ (arguments `(#:tests? #f))
(home-page
"https://github.com/sissaschool/elementpath")
(synopsis
@@ -2592,13 +2603,13 @@ because lxml.etree already has it's own implementation of XPath 1.0.")
(define-public python-lxml
(package
(name "python-lxml")
- (version "4.4.2")
+ (version "4.6.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "lxml" version))
(sha256
- (base32 "01nvb5j8vs9nk4z5s3250b1m22b4d08kffa36if3g1mdygdrvxpg"))))
+ (base32 "0s14r1w2x9sdlcsw8mxiqgw4rz5zs5lpqpxrfyn4a1mkndqqbdrr"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -2621,7 +2632,7 @@ libxml2 and libxslt.")
(define-public python-xmlschema
(package
(name "python-xmlschema")
- (version "1.1.2")
+ (version "1.2.5")
(source (origin
;; Unit tests are not distributed with the PyPI archive.
(method git-fetch)
@@ -2631,21 +2642,20 @@ libxml2 and libxslt.")
(file-name (git-file-name name version))
(sha256
(base32
- "03bz5mp45y4shmlc1gxq1h69vjx60z1acg9cy4kq7fczgx8qg9jw"))))
+ "0rsa75x86gdjalvy4riq7613szb616hff80crx006chyppzdkxmq"))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key (tests? #t) #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(if tests?
- (begin
- (setenv "PYTHONPATH"
- (string-append "./build/lib:"
- (getenv "PYTHONPATH")))
- (invoke "python" "-m" "unittest" "-v"))
- (format #t "test suite not run~%"))
- #t)))))
+ ;; Disable test_export_remote__issue_187, which is known to
+ ;; fail (see:
+ ;; https://github.com/sissaschool/xmlschema/issues/206).
+ (invoke "python" "-m" "unittest" "-v"
+ "-k" "not test_export_remote__issue_187")
+ (format #t "test suite not run~%")))))))
(native-inputs
`(("python-lxml" ,python-lxml))) ;for tests
(propagated-inputs