summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 2736f861a8..77c366b0a2 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -155,6 +155,13 @@ Xfce Desktop Environment.")
;; For the missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
(invoke "dbus-launch" "make" "check")))
+ (add-after 'custom-check 'install-shell-completions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (etc (string-append out "/etc")))
+ (with-directory-excursion "completions"
+ (install-file "xfconf-query"
+ (string-append etc "/bash_completion.d"))))))
(delete 'check))))
(native-inputs
`(("pkg-config" ,pkg-config)