summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm106
1 files changed, 63 insertions, 43 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index b0c2f9dd6a..ae64072c8e 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015, 2016 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2013, 2015, 2017, 2018, 2019, 2021y Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015, 2017, 2018, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2015 Alexander I.Grafov <grafov@gmail.com>
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
@@ -42,6 +42,7 @@
;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Renzo Poddighe <renzo@poddighe.nl>
@@ -49,6 +50,7 @@
;;; Copyright © 2021 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2021 Nikita Domnitskii <nikita@domnitskii.me>
;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
@@ -235,8 +237,7 @@ program.")
(modify-phases %standard-phases
(add-before 'build 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((xrandr (string-append (assoc-ref inputs "xrandr")
- "/bin/xrandr")))
+ (let ((xrandr (search-input-file inputs "/bin/xrandr")))
(substitute* "contrib/etc/xdg/autostart/autorandr.desktop"
(("/usr") (assoc-ref outputs "out")))
(substitute* "autorandr.py"
@@ -425,14 +426,14 @@ avoiding password prompts when X11 forwarding has already been setup.")
(define-public libxkbcommon
(package
(name "libxkbcommon")
- (version "1.0.3")
+ (version "1.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://xkbcommon.org/download/libxkbcommon-"
version ".tar.xz"))
(sha256
(base32
- "0lmwglj16anhpaq0h830xsl1ivknv75i4lir9bk88aq73s2jy852"))))
+ "0ysynzzgzd9jdrh1321r4bgw8wd5zljrlyn5y1a31g39xacf02bv"))))
(build-system meson-build-system)
(inputs
`(("libx11" ,libx11)
@@ -608,7 +609,7 @@ following the mouse.")
(define-public pixman
(package
(name "pixman")
- (version "0.38.4")
+ (version "0.40.0")
(source
(origin
(method url-fetch)
@@ -617,13 +618,17 @@ following the mouse.")
"https://www.cairographics.org/releases/pixman-"
version ".tar.gz"))
(sha256
- (base32 "1ryxzdf048x7wsx4dlvrr1p00gzwfs7lybnhgc7ygbj0dvyxcrns"))
+ (base32 "1z13n96m7x91j25qq9wlkxsbq04wfwjhw66ir17frna06zn0s83d"))
(patches
(search-patches
"pixman-CVE-2016-5296.patch"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ `(#:configure-flags
+ (list
+ "--disable-static"
+ "--enable-timers"
+ "--enable-gnuplot")))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
@@ -634,12 +639,12 @@ following the mouse.")
manipulation, providing features such as image compositing and trapezoid
rasterisation.")
(home-page "http://www.pixman.org/")
- (license license:x11)))
+ (license license:expat)))
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.103")
+ (version "2.4.107")
(source (origin
(method url-fetch)
(uri (string-append
@@ -647,7 +652,7 @@ rasterisation.")
version ".tar.xz"))
(sha256
(base32
- "08h2nnf4w96b4ql7485mvjgbbsb8rwc0qa93fdm1cq34pbyszq1z"))))
+ "127qf1rzhaf13vdd75a58v5q34617hvangjlfnlkcdh37gqcwm65"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -662,9 +667,10 @@ rasterisation.")
#:phases (modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "meson" "test" "--timeout-multiplier" "5"))))))
- (inputs
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "meson" "test" "--timeout-multiplier" "5")))))))
+ (propagated-inputs
`(("libpciaccess" ,libpciaccess)))
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -1440,15 +1446,12 @@ the X.Org X Server version 1.7 and later (X11R7.5 or later).")
(add-after 'split-outputs 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((gtk (assoc-ref outputs "gtk"))
- (python-version
- (@ (guix build python-build-system) python-version))
- (python (assoc-ref inputs "python"))
- (sitedir (string-append gtk "/lib/python"
- (python-version python)
- "/site-packages")))
+ (site-packages (@ (guix build python-build-system)
+ site-packages))
+ (site (site-packages inputs outputs)))
(wrap-program (string-append gtk "/bin/redshift-gtk")
- `("PYTHONPATH" ":" prefix
- (,(string-append sitedir ":" (getenv "PYTHONPATH"))))
+ `("GUIX_PYTHONPATH" ":" prefix
+ (,(string-append site ":" (getenv "GUIX_PYTHONPATH"))))
`("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH"))))
#t))))))
(outputs '("out" "gtk"))
@@ -1561,7 +1564,7 @@ protocol.")
;; to Python libraries.
(wrap-program (string-append (assoc-ref outputs "out")
"/bin/gammastep-indicator")
- `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))
+ `("PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
`("GI_TYPELIB_PATH" ":" prefix
(,(getenv "GI_TYPELIB_PATH")))))))))
(native-inputs
@@ -1696,30 +1699,45 @@ Saver extension) library.")
(license license:gpl3+)))
(define-public xsel
- (package
- (name "xsel")
- (version "1.2.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.vergenet.net/~conrad/software"
- "/xsel/download/xsel-" version ".tar.gz"))
- (sha256
- (base32
- "070lbcpw77j143jrbkh0y1v10ppn1jwmjf92800w7x42vh4cw9xr"))))
- (build-system gnu-build-system)
- (inputs
- `(("libxt" ,libxt)))
- (home-page "http://www.vergenet.net/~conrad/software/xsel/")
- (synopsis "Manipulate X selection")
- (description
- "XSel is a command-line program for getting and setting the contents of
+ ;; The 1.2.0 release no longer compiles with GCC 8 and upper, see:
+ ;; https://github.com/kfish/xsel/commit/d88aa9a8dba9228e6780d6bb5a5720a36f854918.
+ (let ((commit "062e6d373537c60829fa9b5dcddbcd942986b3c3")
+ (revision "1"))
+ (package
+ (name "xsel")
+ (version (git-version "1.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kfish/xsel")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fbf80zsc22vcqp59r9fdx4icxhrkv7l3lphw83326jrmkzy6kri"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "autoreconf" "-vfi"))))))
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (inputs
+ `(("libxt" ,libxt)))
+ (home-page "http://www.vergenet.net/~conrad/software/xsel/")
+ (synopsis "Manipulate X selection")
+ (description
+ "XSel is a command-line program for getting and setting the contents of
the X selection. Normally this is only accessible by manually highlighting
information and pasting it with the middle mouse button.
XSel reads from standard input and writes to standard output by default,
but can also follow a growing file, display contents, delete entries and more.")
- (license (license:x11-style "file://COPYING"
- "See COPYING in the distribution."))))
+ (license (license:x11-style "file://COPYING"
+ "See COPYING in the distribution.")))))
(define-public xdpyprobe
(package
@@ -2725,10 +2743,12 @@ tools to complement clipnotify.")
(gawk (assoc-ref inputs "gawk"))
(util-linux (assoc-ref inputs "util-linux"))
(xdotool (assoc-ref inputs "xdotool"))
- (xsel (assoc-ref inputs "xsel")))
+ (xsel (assoc-ref inputs "xsel"))
+ (guile (search-input-file inputs "bin/guile")))
(for-each
(lambda (prog)
(wrap-script (string-append out "/bin/" prog)
+ #:guile guile
`("PATH" ":" prefix
,(map (lambda (dir)
(string-append dir "/bin"))