summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm58
1 files changed, 45 insertions, 13 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index e5a98edb35..d345bc461d 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Derek Chuank <derekchuank@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1499,6 +1500,35 @@ This is a fork with added support for Wayland using the wlr-gamma-control
protocol.")
(license license:gpl3+))))
+(define-public xwhite
+ (package
+ (name "xwhite")
+ (version "0.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/derekchuank/xwhite/"
+ "releases/download/v" version
+ "/xwhite-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jbnlj5a91ib4anprmylqqnbv9wa73cr7fsc1s54df0a0w5yq8sz"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:tests? #f)) ;No test suite.
+ (native-inputs (list pkg-config))
+ (inputs (list libxrandr))
+ (home-page "https://github.com/derekchuank/xwhite")
+ (synopsis "Adjust the color balance")
+ (description
+ "@command{xwhite} is a command line tool for adjusting the colour
+balance of screen. It is based on xrandr's gamma correction and brightness adjustment.
+As such, it can only be used for X displays and not Wayland displays. It is typically
+used for tuning the color balance and color temperature. It has a similar function as
+@command{redshift -P -g R:G:B -O temperature}, but @command{xwhite} is more flexible
+in that it does not keep the white color fixed, suitable for setting the white color
+to an arbitrary balanced color.")
+ (license license:gpl2)))
+
(define-public gammastep
(package
(name "gammastep")
@@ -2320,16 +2350,16 @@ temperature of the screen.")
(native-inputs
(list pandoc pkg-config))
(inputs
- `(("fontconfig" ,fontconfig)
- ("libX11" ,libx11)
- ("libxcomposite" ,libxcomposite)
- ("libxext" ,libxext)
- ("libxfixes" ,libxfixes)
- ("libxft" ,libxft)
- ("libxmu" ,libxmu)
- ("libxrandr" ,libxrandr)
- ("libxscrnsaver" ,libxscrnsaver)
- ("linux-pam" ,linux-pam)))
+ (list fontconfig
+ libx11
+ libxcomposite
+ libxext
+ libxfixes
+ libxft
+ libxmu
+ libxrandr
+ libxscrnsaver
+ linux-pam))
(home-page "https://github.com/google/xsecurelock")
(synopsis "X11 screen lock utility with the primary goal of security")
(description "@code{xsecurelock} is an X11 screen locker which uses
@@ -2339,9 +2369,11 @@ As a consequence of the modular design, the usual screen locker service
shouldn't be used with @code{xsecurelock}. Instead, you need to add a helper
binary to setuid-binaries:
@example
-(setuid-programs (cons*
- (file-append xsecurelock \"/libexec/xsecurelock/authproto_pam\")
- %setuid-programs))
+(setuid-programs
+ (cons*
+ (setuid-program
+ (program (file-append xsecurelock \"/libexec/xsecurelock/authproto_pam\")))
+ %setuid-programs))
@end example")
(license license:asl2.0)))