summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm51
1 files changed, 43 insertions, 8 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 44f903ccb0..be8d0234f9 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
+;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -104,6 +105,7 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages sphinx)
#:use-module (ice-9 match))
;; packages outside the x.org system proper
@@ -322,18 +324,19 @@ avoiding password prompts when X11 forwarding has already been setup.")
(define-public libxkbcommon
(package
(name "libxkbcommon")
- (version "0.10.0")
+ (version "1.0.1")
(source (origin
(method url-fetch)
(uri (string-append "https://xkbcommon.org/download/libxkbcommon-"
version ".tar.xz"))
(sha256
(base32
- "1wmnl0hngn6vrqrya4r8hvimlkr4jag39yjprls4gyrqvh667hsp"))))
+ "13bcdf2xpjxwbghas0cr448z89qqki2ssgfgswc257y9859v4s5b"))))
(build-system meson-build-system)
(inputs
`(("libx11" ,libx11)
("libxcb" ,libxcb)
+ ("libxml2" ,libxml2)
("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)
("xkeyboard-config" ,xkeyboard-config)))
@@ -358,7 +361,8 @@ system applications; currently that includes Wayland, kmscon, GTK+, Qt,
Clutter, and more. Despite the name, it is not currently used by anything
X11 (yet).")
(license (license:x11-style "file://COPYING"
- "See 'COPYING' in the distribution."))))
+ "See 'COPYING' in the distribution."))
+ (properties '((cpe-name . "xkbcommon")))))
(define-public libfakekey
(package
@@ -498,7 +502,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.101")
+ (version "2.4.102")
(source (origin
(method url-fetch)
(uri (string-append
@@ -506,8 +510,7 @@ rasterisation.")
version ".tar.xz"))
(sha256
(base32
- "19vqbhqljhln0lrpnv3s7y3lkhsdcp76dl8bhqj3cis9ism1pwyx"))
- (patches (search-patches "libdrm-realpath-virtio.patch"))))
+ "0nx0bd9dhymdsd99v4ifib77yjirkvkxf5hzdkbr7qr8dhrzkjwb"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -984,7 +987,8 @@ compact configuration syntax.")
;; This sets the destination when installing the necessary terminal
;; capability data, which are not provided by 'ncurses'. See
;; https://lists.gnu.org/archive/html/bug-ncurses/2009-10/msg00031.html
- `(#:make-flags (list (string-append "TERMINFO="
+ `(#:configure-flags (list "--enable-256-color")
+ #:make-flags (list (string-append "TERMINFO="
(assoc-ref %outputs "out")
"/share/terminfo"))
#:phases
@@ -2436,7 +2440,7 @@ After selection, the clip is put onto the PRIMARY and CLIPBOARD X selections.")
("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
(inputs
- `(("dbus-glib", dbus-glib)
+ `(("dbus-glib" ,dbus-glib)
("glib" ,glib)
("libx11" ,libx11)))
(home-page "https://github.com/qnikst/kbdd")
@@ -2515,3 +2519,34 @@ using @command{dmenu}.")
such as sway, similar to @command{rofi}.")
(home-page "https://hg.sr.ht/~scoopta/wofi")
(license license:gpl3+)))
+
+(define-public dex
+ (package
+ (name "dex")
+ (version "0.9.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/jceb/dex"))
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "03aapcywnz4kl548cygpi25m8adwbmqlmwgxa66v4156ax9dqs86"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f))
+ (inputs
+ `(("python", python)))
+ (native-inputs
+ `(("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/jceb/dex")
+ (synopsis "Execute DesktopEntry files")
+ (description
+ "@command{dex}, @dfn{DesktopEntry Execution}, is a program to generate
+and execute @file{.desktop} files of the Application type.")
+ (license license:gpl3+)))