summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 7150fb28da..565e6e8927 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -93,6 +93,14 @@
(build-system python-build-system)
(arguments
`(#:python ,python-2 ;incompatible with python 3
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "screenlayout/xrandr.py"
+ (("\"xrandr\"") (string-append "\"" (assoc-ref inputs "xrandr")
+ "/bin/xrandr\"")))
+ #t)))
#:tests? #f)) ;no tests
(inputs `(("pygtk" ,python2-pygtk)
("xrandr" ,xrandr)))