summaryrefslogtreecommitdiff
path: root/gnu/packages/wxwidgets.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wxwidgets.scm')
-rw-r--r--gnu/packages/wxwidgets.scm64
1 files changed, 62 insertions, 2 deletions
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 077195cca7..5610a0f3b2 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -4,6 +4,8 @@
;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,6 +29,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
#:use-module (guix build utils)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
@@ -34,6 +37,8 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages photo)
+ #:use-module (gnu packages video)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages sdl)
@@ -70,12 +75,16 @@
(native-inputs
`(("pkg-config" ,pkg-config)))
(arguments
- '(#:configure-flags
+ `(#:configure-flags
'("--with-regex" "--with-libmspack"
"--with-sdl"
"--enable-webview"
"--enable-webkit"
- "--enable-webviewwebkit")
+ "--enable-webviewwebkit"
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--build=aarch64-unknown-linux-gnu")
+ '()))
#:make-flags
(list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))
@@ -97,6 +106,27 @@ and many other languages.")
(package-inputs wxwidgets))))
(name "wxwidgets-gtk2")))
+;; Development version of wxWidgets, required to build against gstreamer-1.x.
+;; This can be removed when wxWidgets is updated to the next stable version.
+(define-public wxwidgets-3.1
+ (package (inherit wxwidgets)
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/wxWidgets/wxWidgets/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append "wxwidgets-" version ".tar.gz"))
+ (sha256
+ (base32 "1yan5ysjwh6a7xw82sfjd1xn0nsy1dn2s0cx9ac7cw19191blc3y"))))
+ (inputs `(("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ,@(package-inputs wxwidgets)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments wxwidgets)
+ ((#:configure-flags flags)
+ `(cons "--enable-mediactrl" ,flags))))))
+
(define-public python2-wxpython
(package
(name "python2-wxpython")
@@ -167,3 +197,33 @@ and many other languages.")
(description "@code{wxpython} provides Python 2 bindings for wxWidgets.")
(home-page "http://wxpython.org/")
(license (package-license wxwidgets))))
+
+(define-public wxsvg
+ (package
+ (name "wxsvg")
+ (version "1.5.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/wxsvg/wxsvg/"
+ version "/wxsvg-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0m3ff8mjiq4hvy8rmxyc9fkpf24xwxhvr3a6jmvr2q5zc41xhz7x"))))
+ (build-system glib-or-gtk-build-system)
+ (inputs
+ `(("wxwidgets" ,wxwidgets-3.1)
+ ("cairo" ,cairo)
+ ("pango" ,pango)
+ ("libexif" ,libexif)
+ ("ffmpeg" ,ffmpeg)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "C++ library to create, manipulate and render SVG files")
+ (description "wxSVG is a C++ library to create, manipulate and render
+@dfn{Scalable Vector Graphics} (SVG) files with the wxWidgets toolkit.")
+ (home-page "http://wxsvg.sourceforge.net")
+
+ ;; wxSVG is licenced under the "wxWindows library licence", which is
+ ;; the LGPL2.0+, with a few extra permissions.
+ (license (list l:lgpl2.0+ (l:fsf-free "file://COPYING")))))