summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm69
1 files changed, 30 insertions, 39 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4740d26024..0d9ad91e77 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2016, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016 Carlo Zancanaro <carlo@zancanaro.id.au>
-;;; Copyright © 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016, 2017, 2018, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2020 Nikita <nikita@n0.is>
;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
;;; Copyright © 2016 Ivan Vilata i Balaguer <ivan@selidor.net>
@@ -81,7 +81,7 @@
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
- #:use-module (gnu packages build-tools) ;for meson-0.55
+ #:use-module (gnu packages build-tools)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages datastructures)
@@ -711,14 +711,10 @@ Features include:
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(icons (string-append out "/share/i3lock-fancy/icons/"))
- (wmctrl (string-append (assoc-ref inputs "wmctrl")
- "/bin/wmctrl"))
- (mconvert (string-append (assoc-ref inputs "imagemagick")
- "/bin/convert"))
- (mimport (string-append (assoc-ref inputs "imagemagick")
- "/bin/import"))
- (awk (string-append (assoc-ref inputs "gawk")
- "/bin/gawk")))
+ (wmctrl (search-input-file inputs "/bin/wmctrl"))
+ (mconvert (search-input-file inputs "/bin/convert"))
+ (mimport (search-input-file inputs "/bin/import"))
+ (awk (search-input-file inputs "/bin/gawk")))
(substitute* "lock"
(("\\$\\(command -V wmctrl\\)") wmctrl)
@@ -1029,9 +1025,7 @@ experience.")
(base32
"0vkwyci4z4jj2aczxkrmj0861j5jczjr8isasa7gml93nlvyw7gv"))))
(build-system meson-build-system)
- (arguments
- `( #:meson ,meson-0.55
- #:build-type "release"))
+ (arguments `(#:build-type "release"))
(native-inputs
`(("pkg-config" ,pkg-config)
("wayland-protocols" ,wayland-protocols)
@@ -1076,7 +1070,8 @@ for wlroots-based Wayland compositors.")
"\"~c\"")))
#t))
(patches
- (search-patches "awesome-reproducible-png.patch"))))
+ (search-patches "awesome-reproducible-png.patch"
+ "awesome-4.3-fno-common.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("asciidoc" ,asciidoc)
@@ -1158,7 +1153,8 @@ for wlroots-based Wayland compositors.")
(setenv "LD_LIBRARY_PATH" cairo)
(setenv "LUA_PATH" (string-append "?.lua;" lua-path))
(setenv "LUA_CPATH" lua-cpath)
- #t)))
+ (setenv "HOME" (getcwd))
+ (setenv "XDG_CACHE_HOME" (getcwd)))))
(replace 'check
(lambda _
;; There aren't any tests, so just make sure the binary
@@ -1409,7 +1405,7 @@ project derived from the original Calm Window Manager.")
(define-public dwl
(package
(name "dwl")
- (version "0.2")
+ (version "0.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1418,7 +1414,7 @@ project derived from the original Calm Window Manager.")
(file-name (git-file-name name version))
(sha256
(base32
- "0r5hsxpckkrq1y7bjfq58rlc5xy45z499rg628q3nh289978ail1"))))
+ "0js8xjc2rx1ml6s58s90jrak5n7vh3kj5na2j4yy3qy0cb501xcm"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -1533,7 +1529,7 @@ functionality to display information about the most commonly used services.")
(define-public wlroots
(package
(name "wlroots")
- (version "0.12.0")
+ (version "0.14.1")
(source
(origin
(method git-fetch)
@@ -1542,12 +1538,10 @@ functionality to display information about the most commonly used services.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "01j38lmgs2c6fq68v8b75pkilia2wsgzgp46ivfbi9hhx47kgcfn"))))
+ (base32 "1sshp3lvlkl1i670kxhwsb4xzxl8raz6769kqvgmxzcb63ns9ay1"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Dlogind-provider=elogind")
- #:meson ,meson-0.55
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-before 'configure 'hardcode-paths
(lambda* (#:key inputs #:allow-other-keys)
@@ -1558,12 +1552,12 @@ functionality to display information about the most commonly used services.")
#t)))))
(propagated-inputs
`(;; As required by wlroots.pc.
- ("elogind" ,elogind)
("eudev" ,eudev)
("libinput" ,libinput)
("libxkbcommon" ,libxkbcommon)
("mesa" ,mesa)
("pixman" ,pixman)
+ ("seatd" ,seatd)
("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)
("xcb-util-errors" ,xcb-util-errors)
@@ -1581,7 +1575,7 @@ modules for building a Wayland compositor.")
(define-public sway
(package
(name "sway")
- (version "1.5.1")
+ (version "1.6.1")
(source
(origin
(method git-fetch)
@@ -1590,7 +1584,7 @@ modules for building a Wayland compositor.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1xsa3h8zhf29p0mi90baxpr76jkd9pd1gr97ky8cnjbcs4isj9j0"))))
+ (base32 "0j4sdbsrlvky1agacc0pcz9bwmaxjmrapjnzscbd2i0cria2fc5j"))))
(build-system meson-build-system)
(arguments
`(#:phases
@@ -1758,7 +1752,7 @@ display a clock or apply image manipulation techniques to the background image."
(inputs `(("date" ,date)
("fmt" ,fmt)
("gtk-layer-shell" ,gtk-layer-shell)
- ("gtkmm" ,gtkmm)
+ ("gtkmm" ,gtkmm-3)
("jsoncpp" ,jsoncpp)
("libdbusmenu" ,libdbusmenu)
("libinput" ,libinput)
@@ -1769,8 +1763,7 @@ display a clock or apply image manipulation techniques to the background image."
("spdlog" ,spdlog)
("wayland" ,wayland)))
(native-inputs
- `(("gcc" ,gcc-8) ; for #include <filesystem>
- ("glib:bin" ,glib "bin")
+ `(("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)
("scdoc" ,scdoc)
("wayland-protocols" ,wayland-protocols)))
@@ -2000,12 +1993,9 @@ productive, customizable lisp based systems.")
(copy-recursively (assoc-ref %build-inputs "source") ".")
(chdir "util/stumpish")
(substitute* "stumpish"
- (("rlwrap") (string-append (assoc-ref %build-inputs "rlwrap")
- "/bin/rlwrap"))
- (("xprop") (string-append (assoc-ref %build-inputs "xprop")
- "/bin/xprop"))
- (("/bin/sh") (string-append (assoc-ref %build-inputs "bash")
- "/bin/bash")))
+ (("rlwrap") (search-input-file %build-inputs "/bin/rlwrap"))
+ (("xprop") (search-input-file %build-inputs "/bin/xprop"))
+ (("/bin/sh") (search-input-file %build-inputs "/bin/bash")))
(install-file "stumpish" (string-append %output "/bin")))))
(home-page "https://github.com/stumpwm/stumpwm-contrib")
(synopsis "StumpWM interactive shell")
@@ -2523,7 +2513,7 @@ shows a notification for the user on the screen.")
(define-public cagebreak
(package
(name "cagebreak")
- (version "1.6.0")
+ (version "1.8.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2532,14 +2522,15 @@ shows a notification for the user on the screen.")
(file-name (git-file-name name version))
(sha256
(base32
- "02gxmypfj75amdd8lwdkkk7imw7lwmghpyk8h9asljy9aq6ymdqp"))))
+ "0296mnzk7qd0zvnhw716jvpp7madjsar373ixx4qcff0m0jwfrxm"))))
(build-system meson-build-system)
(arguments '(#:configure-flags '("-Dxwayland=true")))
(native-inputs
`(("pandoc" ,pandoc)
("pkg-config" ,pkg-config)))
(inputs
- `(("pango" ,pango)
+ `(("libevdev" ,libevdev)
+ ("pango" ,pango)
("wlroots" ,wlroots)))
(home-page "https://github.com/project-repo/cagebreak")
(synopsis "Tiling wayland compositor inspired by ratpoison")
@@ -2580,14 +2571,14 @@ read and write, and compatible with JSON.")
(define-public hikari
(package
(name "hikari")
- (version "2.2.3")
+ (version "2.3.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://hikari.acmelabs.space/releases/"
"hikari-" version ".tar.gz"))
(sha256
- (base32 "1d023cphzi15k434n60l1rp5awxmdijvsxfrm59fmsvd5rjxh9q7"))))
+ (base32 "1jvy21irh6s7czff2hk63spswqibjcjhrpsgmrki5bii9ddi73wy"))))
(build-system gnu-build-system)
(native-inputs
`(("bmake" ,bmake)