summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm47
1 files changed, 41 insertions, 6 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 53dbda5942..4bf621ee27 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -27,6 +27,9 @@
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
+;;; Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
+;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
+;;; Copyright © 2019 Noodles! <nnoodle@chiru.no>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1495,7 +1498,7 @@ compositors that support the layer-shell protocol.")
(define-public stumpwm
(package
(name "stumpwm")
- (version "18.11")
+ (version "19.11")
(source
(origin
(method git-fetch)
@@ -1504,11 +1507,7 @@ compositors that support the layer-shell protocol.")
(commit version)))
(file-name (git-file-name "stumpwm" version))
(sha256
- (base32 "003g1fmh7446ws49866kzny4lrk1wf034dq5fa4m9mq1nzc7cwv7"))
- (patches
- ;; This patch is included in the post-18.11 git master tree
- ;; and can be removed when we move to the next release.
- (search-patches "stumpwm-fix-broken-read-one-line.patch"))))
+ (base32 "1ha8803ll7472kqxsy2xz0v5d4sv8apmc9z631d67m31q0z1m9rz"))))
(build-system asdf-build-system/sbcl)
(native-inputs `(("fiasco" ,sbcl-fiasco)
("texinfo" ,texinfo)))
@@ -1606,3 +1605,39 @@ productive, customizable lisp based systems.")
(define-public sbcl-stumpwm+slynk
(deprecated-package "sbcl-stumpwm-with-slynk" stumpwm+slynk))
+
+(define-public lemonbar
+ (let ((commit "35183ab81d2128dbb7b6d8e119cc57846bcefdb4")
+ (revision "1"))
+ (package
+ (name "lemonbar")
+ (version (git-version "1.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/LemonBoy/bar")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wwqbph392iwz8skaqxb0xpklb1l6yganqz80g4x1fhrnz7idmlh"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no test suite
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("libxcb" ,libxcb)))
+ (native-inputs
+ `(("perl" ,perl)))
+ (home-page "https://github.com/LemonBoy/bar")
+ (synopsis "Featherweight status bar")
+ (description
+ "@code{lemonbar} (formerly known as @code{bar}) is a lightweight
+bar entirely based on XCB. Provides full UTF-8 support, basic
+formatting, RandR and Xinerama support and EWMH compliance without
+wasting your precious memory.")
+ (license license:x11))))