summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f7a9dda800..51034cac4b 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -82,6 +82,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages build-tools) ;for meson-0.55
#:use-module (gnu packages calendar)
+ #:use-module (gnu packages datastructures)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
@@ -908,6 +909,39 @@ experience.")
(home-page "http://fluxbox.org/")
(license license:expat)))
+(define-public fnott
+ (package
+ (name "fnott")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/dnkl/fnott")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xaz13iry3fdjhqk9xzg29kbv7hqj8dzzqxr5mhrj8f2m013jdc3"))))
+ (build-system meson-build-system)
+ (arguments `(#:build-type "release"))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("wayland-protocols" ,wayland-protocols)
+ ("tllist" ,tllist)
+ ("gcc" ,gcc-10) ;TODO: Remove when the default compiler is > GCC 7.
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("wlroots" ,wlroots)
+ ("wayland" ,wayland)
+ ("fcft" ,fcft)
+ ("dbus" ,dbus)
+ ("libpng" ,libpng)))
+ (home-page "https://codeberg.org/dnkl/fnott")
+ (synopsis "Keyboard driven and lightweight Wayland notification daemon")
+ (description "Fnott is a keyboard driven and lightweight notification daemon
+for wlroots-based Wayland compositors.")
+ (license license:expat)))
+
(define-public awesome
(package
(name "awesome")